net-p2p/mldonkey: Replace STRIP_MASK with RESTRICT=strip
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Apr 2019 08:15:47 +0000 (10:15 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 20:17:02 +0000 (22:17 +0200)
Closes: https://bugs.gentoo.org/651456
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-p2p/mldonkey/mldonkey-3.1.5-r1.ebuild
net-p2p/mldonkey/mldonkey-3.1.6-r1.ebuild
net-p2p/mldonkey/mldonkey-3.1.6.ebuild

index 118e1cfae15e8ae83c394d139a1f7c95273c68ab..2f99a446accad23f75b736db48db2d1e6ec59e76 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -27,6 +27,8 @@ RDEPEND="dev-lang/perl
 DEPEND="${RDEPEND}
        >=dev-lang/ocaml-3.10.2[ocamlopt?]"
 
+RESTRICT="!ocamlopt? ( strip )"
+
 MLUSER="p2p"
 
 pkg_setup() {
@@ -111,7 +113,6 @@ src_compile() {
 src_install() {
        local myext=""
        use ocamlopt || myext=".byte"
-       use ocamlopt || export STRIP_MASK="*/bin/*"
        if ! use guionly; then
                for i in mlnet mld_hash get_range copysources subconv; do
                        newbin $i$myext $i
index 242b41314223dfd0e13e68c615fd0a59c0587ecb..a92fc8ae4722a356881df32877ec7c03c2dfe2e7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -29,6 +29,8 @@ RDEPEND="dev-lang/perl
 DEPEND="${RDEPEND}
        >=dev-lang/ocaml-3.10.2[ocamlopt?]"
 
+RESTRICT="!ocamlopt? ( strip )"
+
 MLUSER="p2p"
 
 pkg_setup() {
@@ -113,7 +115,6 @@ src_compile() {
 src_install() {
        local myext=""
        use ocamlopt || myext=".byte"
-       use ocamlopt || export STRIP_MASK="*/bin/*"
        if ! use guionly; then
                for i in mlnet mld_hash get_range copysources subconv; do
                        newbin $i$myext $i
index 861c8017b3ed8dad837ee80c0e9258a4811a943c..06defbcd139a0d1f90ec3215c2a70a01fbf61342 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -27,6 +27,8 @@ RDEPEND="dev-lang/perl
 DEPEND="${RDEPEND}
        >=dev-lang/ocaml-3.10.2[ocamlopt?]"
 
+RESTRICT="!ocamlopt? ( strip )"
+
 MLUSER="p2p"
 
 pkg_setup() {
@@ -109,7 +111,6 @@ src_compile() {
 src_install() {
        local myext=""
        use ocamlopt || myext=".byte"
-       use ocamlopt || export STRIP_MASK="*/bin/*"
        if ! use guionly; then
                for i in mlnet mld_hash get_range copysources subconv; do
                        newbin $i$myext $i