net-print/mtink: remove old
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Mon, 21 May 2018 08:08:44 +0000 (10:08 +0200)
committerAaron Bauman <bman@gentoo.org>
Mon, 21 May 2018 17:03:02 +0000 (13:03 -0400)
Closes: https://github.com/gentoo/gentoo/pull/8511

net-print/mtink/mtink-1.0.16-r1.ebuild [deleted file]

diff --git a/net-print/mtink/mtink-1.0.16-r1.ebuild b/net-print/mtink/mtink-1.0.16-r1.ebuild
deleted file mode 100644 (file)
index eabf2d9..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils base
-
-DESCRIPTION="mtink is a status monitor and inkjet cartridge changer for some Epson printers"
-HOMEPAGE="http://xwtools.automatix.de/"
-SRC_URI="http://xwtools.automatix.de/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE="cups doc X"
-
-DEPEND="X? ( x11-libs/libX11
-               x11-libs/libXpm
-               x11-libs/libXt
-               >=x11-libs/motif-2.3:0 )
-       cups? ( net-print/cups )
-       virtual/libusb:0"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
-       "${FILESDIR}/${P}-options.patch"
-       "${FILESDIR}/${P}-overflow.patch"
-)
-
-src_configure() {
-       if use X ; then
-               ./Configure || die
-       else
-               ./Configure -x || die
-       fi
-}
-
-src_compile() {
-       local mytargets
-       mytargets="ttink detect/askPrinter mtinkd"
-
-       if use X; then
-               mytargets="${mytargets} mtink mtinkc";
-       fi
-
-       emake ${mytargets}
-}
-
-src_install() {
-       dobin ttink detect/askPrinter
-
-       if use X; then
-               dobin mtinkc mtink
-       fi
-
-       dosbin mtinkd
-
-       newinitd "${FILESDIR}"/mtinkd.rc mtinkd
-       newconfd "${FILESDIR}"/mtinkd.confd mtinkd
-
-       if use cups; then
-               exeinto /usr/lib/cups/backend
-               doexe etc/mtink-cups
-       fi
-
-       dodoc README CHANGE.LOG
-       use doc && \
-               dohtml html/*.gif html/*.html
-}
-
-pkg_postinst() {
-       # see #70310
-       chmod 700 /var/mtink /var/run/mtink 2>/dev/null
-
-       elog
-       elog "mtink needs correct permissions to access printer device."
-       elog "To do this you either need to run the following chmod command:"
-       elog "chmod 666 /dev/<device>"
-       elog "or set the suid bit on mtink, mtinkc and ttink in /usr/bin"
-       elog
-}