games-engines/scummvm-tools: Bump to version 2.0.0
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 18 Dec 2017 17:47:26 +0000 (18:47 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 18 Dec 2017 17:48:23 +0000 (18:48 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

games-engines/scummvm-tools/Manifest
games-engines/scummvm-tools/scummvm-tools-2.0.0.ebuild [new file with mode: 0644]

index 3b142513da370115d4a6cd1703acbb352fbfe57e..6656d34c74814fef0116601cff814bd308054f78 100644 (file)
@@ -1 +1,2 @@
 DIST scummvm-tools-1.8.0.tar.xz 864048 BLAKE2B 7e3184bda33c582708be204493cd99504ef7286305ba01d052a95bf317c56630109e963ecd8d26d4f8868bb75e5b0cb22154fe4cb794a01dabe25b11568babbb SHA512 eed0aa0cceef59c42aabe94fe382a4494085c479d310cb624131746a1cbacc37d4a43603a5321167eb5fd4d9d8235fc794bdca5a3417fc4d224213e5409347ed
+DIST scummvm-tools-2.0.0.tar.xz 866668 BLAKE2B 51e6a771f0b1902f9cadc1e84da4b97aa42bc810c781ba238b3dad9ce242792d0de805e6d129607bace36b7a3cb8dc7a7a1a6fd13211320afe6546569b49f0ff SHA512 a4c645f2a05b5f208658bad1a3122115a3077809141f5d4b281414ca32854d14987a8b6d4579f3bdd9d3eeeab880d98e3b540c3f69155197f20a2094a7812c60
diff --git a/games-engines/scummvm-tools/scummvm-tools-2.0.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..c673ff3
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER=3.0
+inherit wxwidgets eutils flag-o-matic
+
+DESCRIPTION="utilities for the SCUMM game engine"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="http://scummvm.org/frs/scummvm-tools/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE="flac iconv mad png vorbis"
+RESTRICT="test" # some tests require external files
+
+RDEPEND=">=dev-libs/boost-1.32
+       sys-libs/zlib
+       x11-libs/wxGTK:${WX_GTK_VER}
+       flac? ( media-libs/flac )
+       iconv? ( virtual/libiconv media-libs/freetype:2 )
+       mad? ( media-libs/libmad )
+       png? ( media-libs/libpng:0 )
+       vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+       app-arch/xz-utils
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.8.0-binprefix.patch"
+)
+
+src_prepare() {
+       default
+
+       need-wxwidgets unicode
+       rm -rf *.bat dists/win32 || die
+       sed -ri -e '/^(CC|CXX)\b/d' Makefile || die
+}
+
+src_configure() {
+       # Not an autoconf script
+       ./configure \
+               --disable-tremor \
+               --enable-verbose-build \
+               --mandir=/usr/share/man \
+               $(use_enable flac) \
+               $(use_enable iconv) \
+               $(use_enable iconv freetype) \
+               $(use_enable mad) \
+               $(use_enable png) \
+               $(use_enable vorbis) || die
+}
+
+src_install() {
+       EXEPREFIX="${PN}-" default
+}