dev-ruby/prawn: Add ruby23, drop ~ia64, ~ppc, ~sparc keywords
authorManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 02:00:05 +0000 (03:00 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 02:00:05 +0000 (03:00 +0100)
Package-Manager: portage-2.3.3

dev-ruby/prawn/prawn-2.1.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/prawn/prawn-2.1.0-r1.ebuild b/dev-ruby/prawn/prawn-2.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..e780e64
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast, Nimble PDF Generation For Ruby"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pdf-core-0.6.1
+       >=dev-ruby/ttfunk-1.4.0"
+ruby_add_bdepend "test? ( dev-ruby/coderay
+       >=dev-ruby/pdf-inspector-1.2.1
+       >=dev-ruby/pdf-reader-1.2
+       )"
+
+all_ruby_prepare() {
+       sed -i -e "/[Bb]undler/d" Rakefile spec/spec_helper.rb || die
+       # Remove failing tests
+       # https://github.com/prawnpdf/prawn/pull/693
+       # https://github.com/prawnpdf/prawn/issues/603
+       sed -i -e "/should process UTF-8 chars/,+9 s/^/#/" spec/line_wrap_spec.rb || die
+       sed -i -e "/shrink_to_fit with special utf-8 text/,+12 s/^/#/" spec/text_spec.rb || die
+}