dev-vcs/mercurial: bumps to 5.4
authorCédric Krier <cedk@gentoo.org>
Sat, 9 May 2020 09:29:38 +0000 (11:29 +0200)
committerCédric Krier <cedk@gentoo.org>
Sat, 9 May 2020 09:30:00 +0000 (11:30 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Cédric Krier <cedk@gentoo.org>
dev-vcs/mercurial/Manifest
dev-vcs/mercurial/mercurial-5.4.ebuild [new file with mode: 0644]

index 2d997abc912deb10165e8c8aa3a683fa45e1101c..98f916aeacbd8b3e0510969b378f3d9118b38d37 100644 (file)
@@ -1,2 +1,3 @@
 DIST mercurial-5.2.2.tar.gz 7333065 BLAKE2B 9cec5a6ebe4693a1b96fe268211aa2eaa06643d5b8812c427757839d5389319f0e2ff3c1ed964a56bf8a3c46f7630321abf508c61691102856dfbdbd72fed662 SHA512 875e75587ab1f1c54edd2f7198dff21e6b287425f215a9d28ef98d5359420df90ca7ef0128ec7b772c4a31dc95b1082b4d6d28f1754968a08408516ba9ec91ee
 DIST mercurial-5.3.2.tar.gz 7514256 BLAKE2B 250ecd5c0a64138cbcda599513efba7b040c0fed0f020c73ade2525e0ef8a9ad06c10c5df4e16eb9bbeb3ab0f2cbb622a65f6d4827b269654c662810ef0385fb SHA512 b0afcf82b51676d2e7592eb9b29f9611d59816399166400027b6c8b29c10c9ddc96b57f7913e78f938b1345bb7ac29ecd4ddc793165b7cf192c3c7a95712cc99
+DIST mercurial-5.4.tar.gz 7722447 BLAKE2B 9abd7b62ca6e44ede626331d080f7a0e8e7fb980c169fbfc2e847549c915b65789e317b674a8317bf58ced3cab4e2de790513e45c6556d32cac649fe23e04fdc SHA512 5f92d653ab74da4696ba7f1402e6cb219c0c514a5eeecb9d7282ab95aef2c6f16d5c8e3d0149525f3dc694a133c713b671ba92327e1b0dc3ad8701d522986d8d
diff --git a/dev-vcs/mercurial/mercurial-5.4.ebuild b/dev-vcs/mercurial/mercurial-5.4.ebuild
new file mode 100644 (file)
index 0000000..25750d8
--- /dev/null
@@ -0,0 +1,171 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="https://www.mercurial-scm.org/"
+SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+chg emacs gpg test tk zsh-completion"
+
+BROKEN_PYTHON="
+       !~dev-python/python-3.5.0
+       !~dev-python/python-3.5.1
+       !~dev-python/python-3.5.2
+       !~dev-python/python-3.6.0
+       !~dev-python/python-3.6.1"
+
+BDEPEND="${BROKEN_PYTHON}"
+
+RDEPEND="${BROKEN_PYTHON}
+       app-misc/ca-certificates
+       dev-python/zstandard[${PYTHON_USEDEP}]
+       gpg? ( app-crypt/gnupg )
+       tk? ( dev-lang/tk )
+       zsh-completion? ( app-shells/zsh )"
+
+DEPEND="emacs? ( >=app-editors/emacs-23.1:* )
+       test? ( app-arch/unzip
+               dev-python/pygments[${PYTHON_USEDEP}] )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+# Too many tests fail #608720
+RESTRICT="test"
+
+python_prepare_all() {
+       # fix up logic that won't work in Gentoo Prefix (also won't outside in
+       # certain cases), bug #362891
+       sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+       # Use absolute import for zstd
+       sed -i -e 's/from \.* import zstd/import zstd/' \
+               mercurial/utils/compression.py \
+               mercurial/wireprotoframing.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile() {
+       filter-flags -ftracer -ftree-vectorize
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+       distutils-r1_python_compile build_ext --no-zstd
+}
+
+python_compile_all() {
+       rm -r contrib/win32 || die
+       if use chg; then
+               emake -C contrib/chg
+       fi
+       if use emacs; then
+               cd contrib || die
+               elisp-compile mercurial.el || die "elisp-compile failed!"
+       fi
+}
+
+python_install() {
+       distutils-r1_python_install build_ext --no-zstd
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       newbashcomp contrib/bash_completion hg
+
+       if use zsh-completion ; then
+               insinto /usr/share/zsh/site-functions
+               newins contrib/zsh_completion _hg
+       fi
+
+       dobin hgeditor
+       if use tk; then
+               dobin contrib/hgk
+       fi
+       python_foreach_impl python_doscript contrib/hg-ssh
+
+       if use emacs; then
+               elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+               elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+       fi
+
+       local RM_CONTRIB=( hgk hg-ssh bash_completion zsh_completion plan9 *.el )
+
+       if use chg; then
+               dobin contrib/chg/chg
+               doman contrib/chg/chg.1
+               RM_CONTRIB+=( chg )
+       fi
+
+       for f in ${RM_CONTRIB[@]}; do
+               rm -rf contrib/${f} || die
+       done
+
+       dodoc -r contrib
+       docompress -x /usr/share/doc/${PF}/contrib
+       doman doc/*.?
+       dodoc CONTRIBUTORS hgweb.cgi
+
+       insinto /etc/mercurial/hgrc.d
+       doins "${FILESDIR}/cacerts.rc"
+}
+
+src_test() {
+       pushd tests &>/dev/null || die
+       rm -rf *svn*                    # Subversion tests fail with 1.5
+       rm -f test-archive*             # Fails due to verbose tar output changes
+       rm -f test-convert-baz*         # GNU Arch baz
+       rm -f test-convert-cvs*         # CVS
+       rm -f test-convert-darcs*       # Darcs
+       rm -f test-convert-git*         # git
+       rm -f test-convert-mtn*         # monotone
+       rm -f test-convert-tla*         # GNU Arch tla
+       rm -f test-largefiles*          # tends to time out
+       if [[ ${EUID} -eq 0 ]]; then
+               einfo "Removing tests which require user privileges to succeed"
+               rm -f test-convert*
+               rm -f test-lock-badness*
+               rm -f test-permissions*
+               rm -f test-pull-permission*
+               rm -f test-journal-exists*
+               rm -f test-repair-strip*
+       fi
+
+       popd &>/dev/null || die
+       distutils-r1_src_test
+}
+
+python_test() {
+       local TEST_DIR
+
+       rm -rf "${TMPDIR}"/test
+       distutils_install_for_testing
+       cd tests || die
+       "${PYTHON}" run-tests.py --verbose \
+               --tmpdir="${TMPDIR}"/test \
+               --with-hg="${TEST_DIR}"/scripts/hg \
+               || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+
+       elog "If you want to convert repositories from other tools using convert"
+       elog "extension please install correct tool:"
+       elog "  dev-vcs/cvs"
+       elog "  dev-vcs/darcs"
+       elog "  dev-vcs/git"
+       elog "  dev-vcs/monotone"
+       elog "  dev-vcs/subversion"
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}