x11-themes/solar-backgrounds: EAPI bump
authorAndreas K. Huettel <dilfridge@gentoo.org>
Fri, 24 Feb 2017 13:37:52 +0000 (14:37 +0100)
committerAndreas K. Huettel <dilfridge@gentoo.org>
Tue, 28 Feb 2017 20:22:50 +0000 (21:22 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

x11-themes/solar-backgrounds/solar-backgrounds-0.92.0.5-r1.ebuild [new file with mode: 0644]

diff --git a/x11-themes/solar-backgrounds/solar-backgrounds-0.92.0.5-r1.ebuild b/x11-themes/solar-backgrounds/solar-backgrounds-0.92.0.5-r1.ebuild
new file mode 100644 (file)
index 0000000..0063581
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=15
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F11_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-2.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${MY_P/-backgrounds/}"
+
+SLOT="0"
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+       insinto /usr/share/backgrounds/solar
+       doins -r solar*.xml {normalish,standard,wide}{,.dual}
+
+       insinto /usr/share/gnome-background-properties
+       doins desktop-*.xml
+}