dev-ros/rqt_gui: Strip ros_packages/ from plugin.xml search path
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:20:09 +0000 (12:20 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:51 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/rqt_gui/files/gentoo.patch [new file with mode: 0644]
dev-ros/rqt_gui/rqt_gui-0.3.2-r1.ebuild [new file with mode: 0644]
dev-ros/rqt_gui/rqt_gui-9999.ebuild

diff --git a/dev-ros/rqt_gui/files/gentoo.patch b/dev-ros/rqt_gui/files/gentoo.patch
new file mode 100644 (file)
index 0000000..abdc30a
--- /dev/null
@@ -0,0 +1,15 @@
+Index: rqt_gui/src/rqt_gui/ros_plugin_provider.py
+===================================================================
+--- rqt_gui.orig/src/rqt_gui/ros_plugin_provider.py
++++ rqt_gui/src/rqt_gui/ros_plugin_provider.py
+@@ -109,6 +109,10 @@ class RosPluginProvider(PluginProvider):
+     def _parse_plugin_xml(self, package_name, plugin_xml):
+         plugin_descriptors = []
++        # Gentoo: strip ros_packages to get the real path.
++        if not os.path.isfile(plugin_xml):
++            plugin_xml = plugin_xml.replace('ros_packages/', '')
++
+         if not os.path.isfile(plugin_xml):
+             qCritical('RosPluginProvider._parse_plugin_xml() plugin file "%s" in package "%s" not found' % (plugin_xml, package_name))
+             return plugin_descriptors
diff --git a/dev-ros/rqt_gui/rqt_gui-0.3.2-r1.ebuild b/dev-ros/rqt_gui/rqt_gui-0.3.2-r1.ebuild
new file mode 100644 (file)
index 0000000..1ba3c35
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the ROS integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
index 8d01cc5e183e5f3da6fc88ed056c57d04194897f..1ba3c35e10d07a45a504eb8b573c773bb56c7cb9 100644 (file)
@@ -18,3 +18,4 @@ IUSE=""
 
 RDEPEND=">=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )