media-gfx/tif22pnm: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 15:07:13 +0000 (16:07 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 15:07:13 +0000 (16:07 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-gfx/tif22pnm/files/tif22pnm-0.14-gentoo.patch
media-gfx/tif22pnm/tif22pnm-0.14.ebuild

index f71c751bd1a50421ee21bbe688f25c3ac69a8353..cc97d68d232291abf67c8f375ff379cd7419d2b5 100644 (file)
@@ -1,5 +1,5 @@
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
 @@ -21,7 +21,6 @@
  dnl Checks for programs.
  AC_PROG_CC
@@ -8,8 +8,8 @@
  dnl ^^^ set it to non-empty, so AC_PROG_CXX won't include `-g'
  dnl AC_PROG_CXX
  dnl AC_PTS_PROG_CFLAGS(fs, -fsigned-char)
---- do.sh
-+++ do.sh
+--- a/do.sh
++++ b/do.sh
 @@ -35,8 +35,8 @@
  if [ x"$CMD" != x ]; then echo "Executing: $CMD"; fi
  
index fd8bd8740a00581bce94efd52d162c49a0d4eefa..cb5142c6aa6e526b0408d0d0d503868011af1459 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit autotools eutils flag-o-matic
+EAPI=7
+
+inherit autotools
 
 DESCRIPTION="tif22pnm and png22pnm command-line converters"
 HOMEPAGE="http://pts.szit.bme.hu/ https://code.google.com/p/sam2p/"
@@ -11,19 +12,24 @@ SRC_URI="https://sam2p.googlecode.com/files/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 
-RDEPEND=">=media-libs/libpng-1.2:0
-       media-libs/tiff:0"
+RDEPEND="
+       media-libs/libpng:0=
+       media-libs/tiff:0="
 DEPEND="${RDEPEND}"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-gentoo.patch
+       "${FILESDIR}"/${P}-math.patch
+)
+
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-gentoo.patch
-       epatch "${FILESDIR}"/${P}-math.patch
+       default
+       mv configure.{in,ac} || die
        eautoreconf
 }
 
 src_install() {
        dobin png22pnm tif22pnm
-       dodoc README
+       einstalldocs
 }