dev-python/jinja: Version bump to 2.9.6
authorManuel Rüger <mrueg@gentoo.org>
Thu, 6 Apr 2017 23:54:17 +0000 (01:54 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Thu, 6 Apr 2017 23:56:17 +0000 (01:56 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-python/jinja/Manifest
dev-python/jinja/jinja-2.9.6.ebuild [new file with mode: 0644]

index 1b0bebb4983bfe41c4d1b591dd7c57f0c84ec67f..17d206e5cafb7bb3891b41cf3cc234721c9f4944 100644 (file)
@@ -3,3 +3,4 @@ DIST Jinja2-2.8.1.tar.gz 358129 SHA256 35341f3a97b46327b3ef1eb624aadea87a535b8f5
 DIST Jinja2-2.8.tar.gz 357055 SHA256 bc1ff2ff88dbfacefde4ddde471d1417d3b304e8df103a7a9437d47269201bf4 SHA512 2e80d6d9ad10dafcce1e6dd24493f5dffc43a17f71a30a650415638e12d3a3891738ebacc569701129214026d062d91a2b10e4f7a2c7b85d801dde26ded1bebb WHIRLPOOL 31adc38738848aa224cceb0d0afb2b85eb080d166ed84f145eb0576eeedfb91cf8d99d7c98b6a6cc6ab4fedf33fdbe3171c80fd559df48036a7441232702e749
 DIST jinja-2.9.4.tar.gz 416465 SHA256 7e7dc5aca0d4e39814a138e360284ad3d92647f480df4236e355acc542f5413b SHA512 60764e31878478c5b5adb60da8ddb8afd5d0982733728b87340f03abb5ad9092350ff8374d42cbd5be84d08904d06f0dbda2ef05f4dfbdc30110af9ab2472e5e WHIRLPOOL 8c0c34691f51373c64a158e043fd8ead01bd7454905ccf1a901901c52da80d35264023b7a65aa5878b87630b323d13d7cfae2470e472cb0204618ae9f607c99a
 DIST jinja-2.9.5.tar.gz 486763 SHA256 86baad86b1210856d784ddf0d243b8fa043f65b1e3cbc07e4fb24cd5b9725d89 SHA512 15c1b79981c4d6fcbb7fa947fe0fd7e43973433c03d6549a84deec8ad70881f7fd0d3a35160bf6371361994f838da7eb478c577de2612e004679ae51bd97b121 WHIRLPOOL 8ef540e81c40b72dbf652b73a63577e052813bc3d263340f55181c9a2320fa8e3f65c37ccaa6f4840d79b63c1c47f12070ae76d61be6fe0a93104e3916a7ff36
+DIST jinja-2.9.6.tar.gz 487185 SHA256 fa4b0ac374a3502d4523673cfdff7a1f6cbd533a13c8050bef6dcd9168142638 SHA512 934e253d9d621fd6d19302ea5e73b571a806c0e31e10ac29b54700ad6649fabf321b00cdc513bb3fb551ee28e83de7f163ce9ef88d232a6c178f4ee5dc2e69b5 WHIRLPOOL f1f576ff18237ef1dddd76c806d4e9256734aeb289aa146c237803e8fc63984dd41e88e8cdb7f45ff9810d9f20c781f040cc04b2cdd02eacb2c35749e5e257ab
diff --git a/dev-python/jinja/jinja-2.9.6.ebuild b/dev-python/jinja/jinja-2.9.6.ebuild
new file mode 100644 (file)
index 0000000..6ac8329
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.python.org/pypi/Jinja2"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/markupsafe[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       !dev-python/jinja:compat"
+DEPEND="${RDEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+       local mydistutilsargs=()
+
+       if [[ ${EPYTHON} == python* ]]; then
+               mydistutilargs+=( --with-debugsupport )
+       fi
+
+       "${@}"
+}
+
+python_compile() {
+       wrap_opts distutils-r1_python_compile
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       py.test || die
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       if use examples ; then
+               docinto examples
+               dodoc -r examples/.
+       fi
+
+       distutils-r1_python_install_all
+
+       insinto /usr/share/vim/vimfiles/syntax
+       doins ext/Vim/*
+}
+
+pkg_postinst() {
+       if ! has_version dev-python/Babel; then
+               elog "For i18n support, please emerge dev-python/Babel."
+       fi
+}