net-im/kadu: Drop 2.1
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 25 Aug 2018 08:53:29 +0000 (10:53 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 25 Aug 2018 08:54:52 +0000 (10:54 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

net-im/kadu/Manifest
net-im/kadu/files/kadu-2.1-port-to-QtQuick-2.3.patch [deleted file]
net-im/kadu/files/kadu-2.1-qt5-compilation.patch [deleted file]
net-im/kadu/kadu-2.1-r2.ebuild [deleted file]
net-im/kadu/metadata.xml

index cff5a2e9fc047729f09630bcb2fbe21eb3dea8c8..01f168c52132323fbae71b57503b37b9857a86b6 100644 (file)
@@ -1,2 +1 @@
-DIST kadu-2.1.tar.bz2 6013519 BLAKE2B 31df1b245ec402a44c60581084d4ec9216636e14a1c11d8609862d982ad08ff3717c16bc9431c21366ef9852eb0035828a11d8010178736ec6b6ebfbadfd971c SHA512 3f0e38aefbaf15f357ae8232b1364deb5954a2464895fafa0a324ad99c7d14c6ba7495bed51d628e04c30bbaaf8e49412c70bbbbf01a40f360406c1afba2384a
 DIST kadu-4.3.tar.bz2 8087786 BLAKE2B b63ce2beebb1fd1f64ae8e85430784c6c7d25a071e00342e33d97a2e49b25c02ab131fb30d591acc11a336427118d4dd23e03d89ad07ef066eca09d0463397db SHA512 fb3d16320894bbfbd50e695d61f305710e59bccce84319389a4047626e97da95ded0b35bc5f7e5d8c2ac96594693b14dd8dd8d46eb1863f89d3eec2e51c73cc9
diff --git a/net-im/kadu/files/kadu-2.1-port-to-QtQuick-2.3.patch b/net-im/kadu/files/kadu-2.1-port-to-QtQuick-2.3.patch
deleted file mode 100644 (file)
index cdfd549..0000000
+++ /dev/null
@@ -1,150 +0,0 @@
-From 6912d8fc02b5ff4d6675656d6c00506c48fdd940 Mon Sep 17 00:00:00 2001
-From: Rafał Przemysław Malinowski <rafal.przemyslaw.malinowski@gmail.com>
-Date: Sat, 21 Mar 2015 01:32:11 +0100
-Subject: [PATCH] gui: ported open chat with from qml to quick 2.3
-
-Signed-off-by: Rafał Przemysław Malinowski <rafal.przemyslaw.malinowski@gmail.com>
----
- cmake/KaduMacros.cmake                                  |  2 +-
- kadu-core/CMakeLists.txt                                |  2 +-
- kadu-core/gui/windows/open-chat-with/open-chat-with.cpp | 11 ++++++-----
- kadu-core/gui/windows/open-chat-with/open-chat-with.h   |  4 ++--
- tests/CMakeLists.txt                                    |  2 +-
- varia/qml/Contact.qml                                   |  2 +-
- varia/qml/ContactsGridView.qml                          |  2 +-
- varia/qml/openChatWith.qml                              |  2 +-
- 8 files changed, 14 insertions(+), 13 deletions(-)
-
-diff --git a/cmake/KaduMacros.cmake b/cmake/KaduMacros.cmake
-index ac9e94e..0a7712a 100644
---- a/cmake/KaduMacros.cmake
-+++ b/cmake/KaduMacros.cmake
-@@ -183,7 +183,7 @@ function (kadu_plugin KADU_PLUGIN_NAME)
-               endforeach ()
-       endif ()
--      qt5_use_modules (${KADU_PLUGIN_NAME} LINK_PRIVATE Core Gui Widgets Network Xml WebKit WebKitWidgets Declarative)
-+      qt5_use_modules (${KADU_PLUGIN_NAME} LINK_PRIVATE Core Gui Network Qml Quick QuickWidgets WebKit WebKitWidgets Widgets Xml)
-       if (UNIX AND NOT APPLE)
-               qt5_use_modules (${KADU_PLUGIN_NAME} LINK_PRIVATE DBus)
-       endif ()
-diff --git a/kadu-core/CMakeLists.txt b/kadu-core/CMakeLists.txt
-index be52339..46317d1 100644
---- a/kadu-core/CMakeLists.txt
-+++ b/kadu-core/CMakeLists.txt
-@@ -205,7 +205,7 @@ if (FAST_LINKING)
-       endif ()
- endif ()
--qt5_use_modules (libkadu LINK_PRIVATE Core Gui Widgets Xml Network WebKit WebKitWidgets Declarative)
-+qt5_use_modules (libkadu LINK_PRIVATE Core Gui Network Qml Quick QuickWidgets WebKit WebKitWidgets Widgets Xml)
- if (UNIX AND NOT APPLE)
-       qt5_use_modules (libkadu LINK_PRIVATE DBus X11Extras)
- endif ()
-diff --git a/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp b/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp
-index 2c14c3f..9ff00d1 100644
---- a/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp
-+++ b/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp
-@@ -21,8 +21,9 @@
-  * along with this program. If not, see <http://www.gnu.org/licenses/>.
-  */
--#include <QtDeclarative/QDeclarativeContext>
--#include <QtDeclarative/QDeclarativeView>
-+#include <QtQml/QQmlContext>
-+#include <QtQuick/QQuickItem>
-+#include <QtQuickWidgets/QQuickWidget>
- #include <QtGui/QKeyEvent>
- #include <QtWidgets/QApplication>
- #include <QtWidgets/QDesktopWidget>
-@@ -97,18 +98,18 @@ OpenChatWith::OpenChatWith() :
-       MainLayout->addWidget(idWidget);
--      BuddiesView = new QDeclarativeView();
-+      BuddiesView = new QQuickWidget();
-       Chain = new ModelChain(this);
-       ListModel = new BuddyListModel(Chain);
-       Chain->setBaseModel(ListModel);
-       Chain->addProxyModel(new TalkableProxyModel(Chain));
--      QDeclarativeContext *declarativeContext = BuddiesView->rootContext();
-+      QQmlContext *declarativeContext = BuddiesView->rootContext();
-       declarativeContext->setContextProperty("buddies", Chain->lastModel());
-       BuddiesView->setSizePolicy(QSizePolicy::Expanding, QSizePolicy::Expanding);
--      BuddiesView->setResizeMode(QDeclarativeView::SizeRootObjectToView);
-+      BuddiesView->setResizeMode(QQuickWidget::SizeRootObjectToView);
-       BuddiesView->setSource(QUrl("file:///" + Application::instance()->pathsProvider()->dataPath() + "qml/openChatWith.qml"));
-       if (BuddiesView->rootObject())
-diff --git a/kadu-core/gui/windows/open-chat-with/open-chat-with.h b/kadu-core/gui/windows/open-chat-with/open-chat-with.h
-index b079b25..8268d8e 100644
---- a/kadu-core/gui/windows/open-chat-with/open-chat-with.h
-+++ b/kadu-core/gui/windows/open-chat-with/open-chat-with.h
-@@ -29,9 +29,9 @@
- #include "open-chat-with-runner.h"
--class QDeclarativeView;
- class QLabel;
- class QPushButton;
-+class QQuickWidget;
- class QVBoxLayout;
- class BuddyListModel;
-@@ -46,7 +46,7 @@ class KADUAPI OpenChatWith : public QWidget, DesktopAwareObject
-       explicit OpenChatWith();
--      QDeclarativeView *BuddiesView;
-+      QQuickWidget *BuddiesView;
-       LineEditWithClearButton *ContactID;
-       QVBoxLayout *MainLayout;
-       OpenChatWithRunner *OpenChatRunner;
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index 0dc1dcf..db7c42d 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -31,7 +31,7 @@ function (kadu_add_test name_)
-       endif ()
-       add_test ("${sourcePath}/${name_}" ${name_})
--      qt5_use_modules (${name_} LINK_PRIVATE Core Gui Widgets Xml Network WebKit WebKitWidgets Declarative Test)
-+      qt5_use_modules (${name_} LINK_PRIVATE Core Gui Network Qml Quick QuickWidgets Test WebKit WebKitWidgets Widgets Xml)
-       # Add libkadu after the plugin so that --as-needed won't drop anything
-       # needed by the plugin.
-diff --git a/varia/qml/Contact.qml b/varia/qml/Contact.qml
-index 54a551e..2257348 100644
---- a/varia/qml/Contact.qml
-+++ b/varia/qml/Contact.qml
-@@ -1,4 +1,4 @@
--import QtQuick 1.1
-+import QtQuick 2.3
- Rectangle
- {
-diff --git a/varia/qml/ContactsGridView.qml b/varia/qml/ContactsGridView.qml
-index 769a419..141931e 100644
---- a/varia/qml/ContactsGridView.qml
-+++ b/varia/qml/ContactsGridView.qml
-@@ -1,4 +1,4 @@
--import QtQuick 1.1
-+import QtQuick 2.3
- Item
- {
-diff --git a/varia/qml/openChatWith.qml b/varia/qml/openChatWith.qml
-index 317133e..cce65b5 100644
---- a/varia/qml/openChatWith.qml
-+++ b/varia/qml/openChatWith.qml
-@@ -1,4 +1,4 @@
--import QtQuick 1.1
-+import QtQuick 2.3
- Item
- {
---
-libgit2 0.24.0
diff --git a/net-im/kadu/files/kadu-2.1-qt5-compilation.patch b/net-im/kadu/files/kadu-2.1-qt5-compilation.patch
deleted file mode 100644 (file)
index 68120a4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN kadu-2.1/kadu-core/os/single-application/single-application.cpp my/kadu-core/os/single-application/single-application.cpp
---- kadu-2.1/kadu-core/os/single-application/single-application.cpp    2015-03-24 22:13:18.000000000 +0100
-+++ my/kadu-core/os/single-application/single-application.cpp  2015-07-05 21:08:09.044685214 +0200
-@@ -26,6 +26,7 @@
- #include "long-lived-lock-file.h"
- #include <QtCore/QCoreApplication>
-+#include <QtCore/QDataStream>
- #include <QtCore/QDir>
- #include <QtCore/QRegExp>
- #include <QtNetwork/QLocalServer>
diff --git a/net-im/kadu/kadu-2.1-r2.ebuild b/net-im/kadu/kadu-2.1-r2.ebuild
deleted file mode 100644 (file)
index ad5ee91..0000000
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit cmake-utils flag-o-matic
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="An open source Gadu-Gadu and Jabber/XMPP protocol Instant Messenger client"
-HOMEPAGE="http://www.kadu.net"
-SRC_URI="http://download.kadu.im/stable/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
-SLOT="0"
-IUSE="+gadu mpd otr phonon sdk speech spell xmpp"
-REQUIRED_USE="
-       || (
-               gadu
-               xmpp
-       )
-"
-COMMON_DEPEND="
-       app-crypt/qca:2[qt5(+),ssl]
-       >=dev-libs/injeqt-1.0.0
-       >=dev-qt/qtcore-5.2.0:5
-       >=dev-qt/qtdbus-5.2.0:5
-       >=dev-qt/qtdeclarative-5.2.0:5
-       >=dev-qt/qtgui-5.2.0:5
-       >=dev-qt/qtmultimedia-5.2.0:5
-       >=dev-qt/qtnetwork-5.2.0:5
-       >=dev-qt/qtscript-5.2.0:5
-       >=dev-qt/qtsql-5.2.0:5
-       >=dev-qt/qtsvg-5.2.0:5
-       >=dev-qt/qtwebkit-5.2.0:5
-       >=dev-qt/qtwidgets-5.2.0:5
-       >=dev-qt/qtx11extras-5.2.0:5
-       >=dev-qt/qtxml-5.2.0:5
-       >=dev-qt/qtxmlpatterns-5.2.0:5
-       >=app-arch/libarchive-2.6[lzma]
-       x11-libs/libX11
-       x11-libs/libXext
-       x11-libs/libXScrnSaver
-       gadu? ( >=net-libs/libgadu-1.11.1[threads] )
-       mpd? ( media-libs/libmpdclient )
-       otr? (
-               >=dev-libs/libgcrypt-1.2.2:0
-               >=net-libs/libotr-4.1.0
-       )
-       phonon? ( media-libs/phonon[qt5(+)] )
-       spell? ( app-text/enchant )
-       xmpp? (
-               net-dns/libidn
-               sys-libs/zlib
-       )
-"
-DEPEND="${COMMON_DEPEND}
-       >=dev-qt/linguist-tools-5.2.0:5
-       x11-base/xorg-proto
-"
-RDEPEND="${COMMON_DEPEND}
-       speech? ( app-accessibility/powiedz )
-"
-
-PATCHES=(
-       "${FILESDIR}/${P}-qt5-compilation.patch"
-       "${FILESDIR}/${P}-port-to-QtQuick-2.3.patch"
-)
-
-PLUGINS='
-antistring
-auto_hide
-autoaway
-autoresponder
-autostatus
-cenzor
-chat_notify
-config_wizard
-desktop_docking
-docking
-emoticons
-encryption_ng
-encryption_ng_simlite
-exec_notify
-ext_sound
-falf_mediaplayer
-filedesc
-firewall
-freedesktop_notify
-hints
-history
-idle
-imagelink
-last_seen
-mediaplayer
-mprisplayer_mediaplayer
-pcspeaker
-qt4_docking
-qt4_docking_notify
-screenshot simpleview
-single_window
-sms
-sound
-sql_history
-tabs
-word_fix
-'
-
-src_configure() {
-       # Filter out dangerous flags
-       filter-flags -fno-rtti
-       strip-unsupported-flags
-
-       # Ensure -DQT_NO_DEBUG is added
-       append-cppflags -DQT_NO_DEBUG
-
-       # Plugin selection
-       use gadu && PLUGINS+=' gadu_protocol history_migration profiles_import'
-       use mpd && PLUGINS+=' mpd_mediaplayer'
-       use otr && PLUGINS+=' encryption_otr'
-       use phonon && PLUGINS+=' phonon_sound'
-       use speech && PLUGINS+=' speech'
-       use spell && PLUGINS+=' spellchecker'
-       use xmpp && PLUGINS+=' jabber_protocol'
-
-       # Configure package
-       local mycmakeargs=(
-               -DBUILD_DESCRIPTION='Gentoo Linux'
-               -DCOMPILE_PLUGINS="${PLUGINS}"
-               -DNETWORK_IMPLEMENTATION="Qt"
-               -DINSTALL_SDK=$(usex sdk)
-               -DWITH_ENCHANT=$(usex spell)
-       )
-       unset PLUGINS
-
-       cmake-utils_src_configure
-}
index e884cc37b59ade9547752f042b9757307c98f402..6bf7f3370862e65c3ff67c67fd2f0a5b1b0ae4cb 100644 (file)
@@ -9,7 +9,6 @@
                <flag name="gadu">Enables Gadu communication protocol</flag>
                <flag name="mpd">Enables Music Player Daemon support</flag>
                <flag name="otr">Enable char encryption via OTR library</flag>
-               <flag name="phonon">Enables phonon audio plugin</flag>
                <flag name="sdk">Install Kadu SDK (cmake module, API headers)</flag>
                <flag name="speech">Enables speech module</flag>
        </use>