dev-games/aseprite: remove unused patches.
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Tue, 3 Oct 2017 18:35:46 +0000 (20:35 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 3 Oct 2017 22:03:46 +0000 (00:03 +0200)
Closes: https://github.com/gentoo/gentoo/pull/5852

dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch [deleted file]
dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch [deleted file]

diff --git a/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch b/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch
deleted file mode 100644 (file)
index 9f50c25..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-Description: fix FTBFS with --as-needed linker option
- Libraries must be placed after object files in command line.
-Author: Ilya Barygin <randomaction@ubuntu.com>
-
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -135,6 +135,10 @@
- # All libraries for .exe files
- set(all_libs ${aseprite_libraries} ${libs3rdparty} ${sys_libs})
-+if(LIBALLEGRO4_LINK_FLAGS)
-+  set(all_libs ${all_libs} ${LIBALLEGRO4_LINK_FLAGS})
-+endif()
-+
- ######################################################################
- # ASEPRITE libraries
-@@ -405,10 +409,6 @@
- add_executable(aseprite WIN32 main.cpp ${win32_resources} ${x11_resources})
- target_link_libraries(aseprite ${all_libs})
--if(LIBALLEGRO4_LINK_FLAGS)
--  set_target_properties(aseprite
--    PROPERTIES LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS})
--endif()
- install(TARGETS aseprite
-   RUNTIME DESTINATION bin)
-@@ -450,8 +450,7 @@
-     endif()
-     if(LIBALLEGRO4_LINK_FLAGS)
--      set_target_properties(${testname}
--      PROPERTIES LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS})
-+      target_link_libraries(${testname} ${LIBALLEGRO4_LINK_FLAGS})
-     endif()
-     if(extra_definitions)
diff --git a/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch b/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch
deleted file mode 100644 (file)
index 8f3027d..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-From 169edeaa69cce2670213c39232a249a487670883 Mon Sep 17 00:00:00 2001
-From: hasufell <hasufell@hasufell.de>
-Date: Sun, 2 Nov 2014 16:58:33 +0100
-Subject: [PATCH] Fix underlinking with USE_SHARED_ALLEGRO4=ON
-
----
- src/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 21c3352..0ce11d2 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -58,6 +58,7 @@ if(USE_SHARED_ALLEGRO4)
-     OUTPUT_VARIABLE LIBALLEGRO4_LINK_FLAGS
-     OUTPUT_STRIP_TRAILING_WHITESPACE)
-+  set(LIBALLEGRO4_LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS} ${PLATFORM_LIBS})
-   include_directories(${LIBALLEGRO4_INCLUDE_DIR})
- else()
-   add_definitions(-DALLEGRO4_WITH_RESIZE_PATCH)