sys-devel/sparse: pin to specific LLVM slot
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 26 Feb 2020 18:46:00 +0000 (18:46 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 26 Feb 2020 18:46:14 +0000 (18:46 +0000)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/sparse/sparse-0.6.1.ebuild
sys-devel/sparse/sparse-9999.ebuild

index 8828d2b92304db1d4fb77d7338697fe700d514cc..8df52ef8a1e598cd51f4c31a1d1311008f03af54 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit eutils multilib toolchain-funcs
+inherit eutils llvm multilib toolchain-funcs
 
 DESCRIPTION="C semantic parser"
 HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
@@ -22,8 +22,10 @@ SLOT="0"
 IUSE="gtk llvm test xml"
 RESTRICT="!test? ( test )"
 
+LLVM_MAX_SLOT=9
+
 RDEPEND="gtk? ( x11-libs/gtk+:2 )
-       llvm? ( >=sys-devel/llvm-3.0 )
+       llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
        xml? ( dev-libs/libxml2 )"
 DEPEND="${RDEPEND}
        gtk? ( virtual/pkgconfig )
index fa4c7a97fab9699e8dd7c83b44f3e6f62d490be2..8df52ef8a1e598cd51f4c31a1d1311008f03af54 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit eutils multilib toolchain-funcs
+inherit eutils llvm multilib toolchain-funcs
 
 DESCRIPTION="C semantic parser"
 HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
@@ -22,8 +22,10 @@ SLOT="0"
 IUSE="gtk llvm test xml"
 RESTRICT="!test? ( test )"
 
+LLVM_MAX_SLOT=9
+
 RDEPEND="gtk? ( x11-libs/gtk+:2 )
-       llvm? ( >=sys-devel/llvm-3.0 )
+       llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
        xml? ( dev-libs/libxml2 )"
 DEPEND="${RDEPEND}
        gtk? ( virtual/pkgconfig )