Fix SRC_URI, rename properly
authorAlec Warner <antarus@gentoo.org>
Sat, 30 Dec 2006 07:03:42 +0000 (07:03 +0000)
committerAlec Warner <antarus@gentoo.org>
Sat, 30 Dec 2006 07:03:42 +0000 (07:03 +0000)
Package-Manager: portage-5386-svn

app-emulation/frodo/ChangeLog
app-emulation/frodo/files/digest-frodo-4.1b [new file with mode: 0644]
app-emulation/frodo/files/frodo-4.1b-gentoo.diff [new file with mode: 0644]
app-emulation/frodo/frodo-4.1b.ebuild [new file with mode: 0644]

index 9719e5ace5f435f2feee32b212d5aa2e61117fc0..0fb4271cdef40d3859a91912c7344ef973322b43 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-emulation/frodo
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/frodo/ChangeLog,v 1.7 2006/12/21 22:50:10 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/frodo/ChangeLog,v 1.8 2006/12/30 07:03:42 antarus Exp $
+
+*frodo-4.1b (30 Dec 2006)
+
+  30 Dec 2006; Alec Warner <antarus@gentoo.org>
+  -files/frodo-4.1-gentoo.diff, +files/frodo-4.1b-gentoo.diff,
+  -frodo-4.1.ebuild, +frodo-4.1b.ebuild:
+  Fix SRC_URI, rename properly
 
   21 Dec 2006; Danny van Dyk <kugelfang@gentoo.org> frodo-4.1.ebuild:
   QA: export CFLAGS -> append-flags.
diff --git a/app-emulation/frodo/files/digest-frodo-4.1b b/app-emulation/frodo/files/digest-frodo-4.1b
new file mode 100644 (file)
index 0000000..da2b887
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 095b9f21c03204cc13f7f249e8866cd9 FrodoV4_1b.Src.tar.gz 377002
+RMD160 b08231f0f1121d4f802ce08407a6e6c371905bd3 FrodoV4_1b.Src.tar.gz 377002
+SHA256 ffae146dc20458698acf5ccc384dc32317cea1df0c95b44b5d47cca8b26bc986 FrodoV4_1b.Src.tar.gz 377002
diff --git a/app-emulation/frodo/files/frodo-4.1b-gentoo.diff b/app-emulation/frodo/files/frodo-4.1b-gentoo.diff
new file mode 100644 (file)
index 0000000..97591fd
--- /dev/null
@@ -0,0 +1,83 @@
+--- configure.in.orig  2003-04-17 03:59:57.000000000 -0400
++++ configure.in       2003-04-17 04:00:28.000000000 -0400
+@@ -10,11 +10,6 @@
+ AC_PROG_CPP
+ AC_PROG_MAKE_SET
+-dnl Don't want the default "-O2 -g" that autoconf uses for gcc.
+-if [[ x"$GXX" = "xyes" ]]; then
+-  CFLAGS="-O2 -g -fomit-frame-pointer -Wall -Wno-unused -Wno-format"
+-fi
+-
+ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
+ UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
+--- C64_x.i.orig       2003-04-17 04:20:41.000000000 -0400
++++ C64_x.i    2003-04-17 04:21:03.000000000 -0400
+@@ -100,7 +100,7 @@
+       gui = 0;
+ #else
+       // try to start up Tk gui.
+-      gui = new CmdPipe("wish", "TkGui.tcl");
++      gui = new CmdPipe("wish", "/usr/bin/TkGui.tcl");
+       if (gui) {
+               if (gui->fail) {
+                       delete gui; gui = 0;
+--- main.cpp.orig      2003-04-17 04:32:24.000000000 -0400
++++ main.cpp   2003-04-17 04:33:20.000000000 -0400
+@@ -24,10 +24,10 @@
+ #define CHAR_ROM_FILE "FrodoRsrc:Char_ROM"
+ #define FLOPPY_ROM_FILE       "FrodoRsrc:1541_ROM"
+ #else
+-#define BASIC_ROM_FILE        "Basic ROM"
+-#define KERNAL_ROM_FILE       "Kernal ROM"
+-#define CHAR_ROM_FILE "Char ROM"
+-#define FLOPPY_ROM_FILE       "1541 ROM"
++#define BASIC_ROM_FILE        "/usr/share/frodo/Basic ROM"
++#define KERNAL_ROM_FILE       "/usr/share/frodo/Kernal ROM"
++#define CHAR_ROM_FILE "/usr/share/frodo/Char ROM"
++#define FLOPPY_ROM_FILE       "/usr/share/frodo/1541 ROM"
+ #endif
+--- Prefs.cpp.orig     2003-04-17 04:34:05.000000000 -0400
++++ Prefs.cpp  2003-04-17 04:38:07.000000000 -0400
+@@ -25,7 +25,7 @@
+ Prefs::Prefs()
+ {
+-      NormalCycles = 63;
++      NormalCycles = 3;
+       BadLineCycles = 23;
+       CIACycles = 63;
+       FloppyCycles = 64;
+@@ -39,7 +39,7 @@
+       for (int i=0; i<4; i++)
+               DriveType[i] = DRVTYPE_DIR;
+-      strcpy(DrivePath[0], "64prgs");
++      strcpy(DrivePath[0], "/usr/share/frodo/64prgs");
+       strcpy(DrivePath[1], "");
+       strcpy(DrivePath[2], "");
+       strcpy(DrivePath[3], "");
+--- TkGui.tcl.orig     2003-04-17 04:41:53.000000000 -0400
++++ TkGui.tcl  2003-04-17 04:42:45.000000000 -0400
+@@ -9,15 +9,15 @@
+ proc defaults {} {
+       global pref
+-      set pref(NormalCycles) "63"
++      set pref(NormalCycles) "3"
+       set pref(BadLineCycles) "23"
+       set pref(CIACycles) "63"
+       set pref(FloppyCycles) "64"
+       set pref(SkipFrames) "4"
+       set pref(DriveType8) "DIR"
+-      set pref(DrivePath8) "./64prgs"
++      set pref(DrivePath8) "~/64prgs"
+       set pref(DriveType9) "D64"
+-      set pref(DrivePath9) "./disk1.d64"
++      set pref(DrivePath9) "~/disk1.d64"
+       set pref(DriveType10) "DIR"
+       set pref(DrivePath10) ""
+       set pref(DriveType11) "DIR"
diff --git a/app-emulation/frodo/frodo-4.1b.ebuild b/app-emulation/frodo/frodo-4.1b.ebuild
new file mode 100644 (file)
index 0000000..f4a533f
--- /dev/null
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/frodo/frodo-4.1b.ebuild,v 1.1 2006/12/30 07:03:42 antarus Exp $
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="latest"
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An excellent Commodore 64 Emulator"
+HOMEPAGE="http://frodo.cebix.net/"
+SRC_URI="http://frodo.cebix.net/downloads/FrodoV4_1b.Src.tar.gz"
+
+LICENSE="Frodo"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE=""
+S="${WORKDIR}/Frodo-4.1b"
+
+RDEPEND=">=media-libs/libsdl-1.2
+       dev-lang/tcl
+       dev-lang/tk"
+
+src_compile() {
+       cd ${S}
+       append-flags "-DX_USE_SHM"
+       mv TkGui.tcl ${S}/Src
+       cd ${S}/Src
+       epatch ${FILESDIR}/${P}-gentoo.diff
+       rm configure
+       autoconf
+       econf || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       cd ${S}/Src
+       dobin Frodo FrodoPC FrodoSC TkGui.tcl
+       cd ${S}
+       dodir /usr/share/${PN}
+       insinto /usr/share/${PN}
+       doins \
+               "1541 ROM" \
+               "Basic ROM" \
+               "Char ROM" \
+               "Kernal ROM"
+       dodir /usr/share/${PN}/64prgs
+       cd ${S}/64prgs
+       insinto /usr/share/${PN}/64prgs
+       doins \
+               3fff \
+               colorbars \
+               d011h3 \
+               dadb \
+               de00all \
+               dycp \
+               fld \
+               lrborder \
+               sprsync \
+               stretch \
+               tech-tech \
+               text26
+       dohtml -r ${S}/Docs/*.html
+}
+
+pkg_postinst() {
+       einfo
+       einfo " READ THE DOCS!  The documentation can be found at:"
+       einfo "   /usr/share/doc/${PF}/html/"
+       einfo
+       einfo " Getting this program to work requires some experimentation with the"
+       einfo " settings.  The three executables you can use are:"
+       einfo
+       einfo "   Frodo   (normal)"
+       einfo "   FrodoPC (faster)"
+       einfo "   FrodoSC (slower than the other two, but most compatible)"
+       einfo
+       einfo " We recommend that you run FrodoSC with the following settings:"
+       einfo
+       einfo "   1.  Limit Speed = enabled"
+       einfo "   2.  Map / = enabled"
+       einfo "   3.  Emulate 1541 CPU (for copy-protected games)"
+       einfo "   4.  Sprites, Sprite Collisions = enabled"
+       einfo "   5.  SID Emulation = Digital"
+       einfo "   6.  SID Filters = enabled"
+       einfo
+       einfo " You will probably need to occasionally change these settings"
+       einfo " depending upon which programs you try to run, or you may need to run"
+       einfo " Frodo or FrodoPC if your machine is too slow."
+       einfo
+       einfo " Most Commodore 64 applications load by first pointing to the D64"
+       einfo " file in preferences, then:"
+       einfo "      LOAD \"*\",8,1"
+       einfo " then:"
+       einfo "      RUN"
+       einfo
+       einfo " Remember that the keyboard is mapped to the C64 layout.  So to type"
+       einfo " the first command above you would use the following sequence:"
+       einfo "     LOAD [SHIFT-2][RIGHT-BRACKET][SHIFT-2],8,1"
+       einfo
+       einfo
+       einfo " For a complete source of C64 programs, try visiting:"
+       einfo "   http://www.c64unlimited.net/"
+       einfo
+}