sys-libs/newlib: drop old, bug #713284
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 17 May 2020 09:33:19 +0000 (10:33 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 17 May 2020 09:33:35 +0000 (10:33 +0100)
Bug: https://bugs.gentoo.org/713284
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/newlib/Manifest
sys-libs/newlib/newlib-3.1.0.ebuild [deleted file]

index a0726ef035a414c8571e0d75c66f977eeb7e1e32..12a1c1b30174c511d71ba2973cd6fa2ceac59d12 100644 (file)
@@ -1,2 +1 @@
-DIST newlib-3.1.0.tar.gz 17958952 BLAKE2B 3a84ae81fc07e442a4ed3da7a78e7ede34cc7e24b5d1c66a12624ed808e5f85f134751fcea0e4ce9eb39df287a582821f751a8610a088c149895b5e38eb06989 SHA512 efc4c3ab7153387780d141386bca5d3e20c9d25ae3e6b87cf94c8df9d301ce5926dacdff9bd33aeb9781559d933c3d0ae77f4e5b46120d90792f75dbfde702c7
 DIST newlib-3.3.0.tar.gz 18361083 BLAKE2B bdc81427955d0a2f550bf2973ca82c0b8b55aa170565cdf1cfe8ac926257fad6d3e860ce7b2e286949ab21be2677378b5b6d3c743c05fe8aa6df8a8c34a16945 SHA512 2f0c6666487520e1a0af0b6935431f85d2359e27ded0d01d02567d0d1c6479f2f0e6bbc60405e88e46b92c2a18780a01a60fc9281f7e311cfd40b8d5881d629c
diff --git a/sys-libs/newlib/newlib-3.1.0.ebuild b/sys-libs/newlib/newlib-3.1.0.ebuild
deleted file mode 100644 (file)
index db1a3fa..0000000
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://sourceware.org/git/newlib-cygwin.git"
-       inherit git-r3
-else
-       SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
-       KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
-       if [[ ${CATEGORY} == cross-* ]] ; then
-               export CTARGET=${CATEGORY#cross-}
-       fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode headers-only nano"
-RESTRICT="strip"
-
-NEWLIBBUILD="${WORKDIR}/build"
-NEWLIBNANOBUILD="${WORKDIR}/build.nano"
-NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
-
-# Adding -U_FORTIFY_SOURCE to counter the effect of Gentoo's
-# auto-addition of _FORTIFY_SOURCE at gcc site: bug #656018#c4
-# Currently newlib can't be built itself when _FORTIFY_SOURCE
-# is set.
-CFLAGS_FULL="-ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-
-pkg_setup() {
-       # Reject newlib-on-glibc type installs
-       if [[ ${CTARGET} == ${CHOST} ]] ; then
-               case ${CHOST} in
-                       *-newlib|*-elf) ;;
-                       *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
-               esac
-       fi
-}
-
-src_configure() {
-       # we should fix this ...
-       unset LDFLAGS
-       CHOST=${CTARGET} strip-unsupported-flags
-       CCASFLAGS_ORIG="${CCASFLAGS}"
-       CFLAGS_ORIG="${CFLAGS}"
-
-       local myconf=(
-               # Disable legacy syscall stub code in newlib.  These have been
-               # moved to libgloss for a long time now, so the code in newlib
-               # itself just gets in the way.
-               --disable-newlib-supplied-syscalls
-       )
-       [[ ${CTARGET} == "spu" ]] \
-               && myconf+=( --disable-newlib-multithread ) \
-               || myconf+=( $(use_enable threads newlib-multithread) )
-
-       mkdir -p "${NEWLIBBUILD}"
-       cd "${NEWLIBBUILD}"
-
-       export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
-       export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
-       ECONF_SOURCE=${S} \
-       econf \
-               $(use_enable unicode newlib-mb) \
-               $(use_enable nls) \
-               "${myconf[@]}"
-
-       # Build newlib-nano beside newlib (original)
-       # Based on https://tracker.debian.org/media/packages/n/newlib/rules-2.1.0%2Bgit20140818.1a8323b-2
-       if use nano ; then
-               mkdir -p "${NEWLIBNANOBUILD}" || die
-               cd "${NEWLIBNANOBUILD}" || die
-               export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
-               export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
-               ECONF_SOURCE=${S} \
-               econf \
-                       $(use_enable unicode newlib-mb) \
-                       $(use_enable nls) \
-                       --enable-newlib-reent-small \
-                       --disable-newlib-fvwrite-in-streamio \
-                       --disable-newlib-fseek-optimization \
-                       --disable-newlib-wide-orient \
-                       --enable-newlib-nano-malloc \
-                       --disable-newlib-unbuf-stream-opt \
-                       --enable-lite-exit \
-                       --enable-newlib-global-atexit \
-                       --enable-newlib-nano-formatted-io \
-                       ${myconf}
-       fi
-}
-
-src_compile() {
-       export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
-       export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
-       emake -C "${NEWLIBBUILD}"
-
-       if use nano ; then
-               export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
-               export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
-               emake -C "${NEWLIBNANOBUILD}"
-       fi
-}
-
-src_install() {
-       cd "${NEWLIBBUILD}" || die
-       emake -j1 DESTDIR="${D}" install
-
-       if use nano ; then
-               cd "${NEWLIBNANOBUILD}" || die
-               emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
-               # Rename nano lib* files to lib*_nano and move to the real ${D}
-               local nanolibfiles=""
-               nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|rdimon\)\.a" -print)
-               for f in ${nanolibfiles}; do
-                       local l="${f##${NEWLIBNANOTMPINSTALL}}"
-                       mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
-               done
-
-               # Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
-               mkdir -p "${D}/usr/${CTARGET}/include/newlib-nano" || die
-               mv "${NEWLIBNANOTMPINSTALL}/usr/${CTARGET}/include/newlib.h" \
-                       "${D}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
-       fi
-
-       # minor hack to keep things clean
-       rm -rf "${D}"/usr/share/info || die
-       rm -rf "${D}"/usr/info || die
-}