dev-ruby/msgpack: backport fix for bug 582968 to x86-keyworded version
authorHans de Graaff <graaff@gentoo.org>
Mon, 30 May 2016 18:10:29 +0000 (20:10 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 30 May 2016 18:11:35 +0000 (20:11 +0200)
Package-Manager: portage-2.2.28

dev-ruby/msgpack/msgpack-0.7.4.ebuild

index d6f6e81f595fe0dc81d62ca502bda31e4a0369b1..bb9d9cc3c81f46ada1fa917412bc1956459180cd 100644 (file)
@@ -33,6 +33,10 @@ all_ruby_prepare() {
 
 each_ruby_configure() {
        ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+
+       # rb_num2int is not inlined on 32 bit arches but also not explicitly
+       # defined, bug 582968
+       sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
 }
 
 each_ruby_compile() {