games-fps/ut2003-bonuspack-cm: Fix broken SRC_URI
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 26 Oct 2019 16:21:01 +0000 (17:21 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 26 Oct 2019 16:25:41 +0000 (17:25 +0100)
The new download is a slightly different size and requires unpack_zip
to work.

Closes: https://bugs.gentoo.org/640552
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-fps/ut2003-bonuspack-cm/Manifest
games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild

index c79a67927b09edeee068d2e2342f35393d4b2a23..b62d6451a53cbf6439a752980269d5249ad91dfd 100644 (file)
@@ -1 +1 @@
-DIST cbp2003.zip 149198671 BLAKE2B c5f7352b7fb1e0e6a18c99a6212cd5cb4e5e6144988534f91aed93bf33b031d437e86eebf239f0a49fa20b90ca0ded09e912a96b798bc855d527423f2a299ba7 SHA512 92e136c03f1385a28163718cc6ef1c36e46fbad14c74d0f266dfe3d9f4a5093e1bd02dde54e68f70539ba2c4ee163b1e886529f7e734059a85223ab6f853a474
+DIST cbp2003.zip 149198696 BLAKE2B d6319e3605752e309411b16358696cdf0559b3cc6acedfae2f063eedb4ee98fefb470e9ff601cdce46821eaaa3f7c0ef3c13ddc2ce3639842ec98e1e68fefb85 SHA512 382ea605b7ce89654b7a58dfd1b36f0624bb0ac63aff6a07f1942dd3c8715ac6d79812828f2f28e2bd1b162673147e0ab8653ac67b4ee5d936e8840dede8e408
index 5e55eb9e95194ceeb0e55419a9c14a1863fa3409..d42bd801c5eda63d81d6969ed860d478b88af018 100644 (file)
@@ -2,12 +2,12 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-inherit games
 
-IUSE=""
+inherit games unpacker
+
 DESCRIPTION="Community Bonus Pack for UT2003"
 HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2003"
-SRC_URI="https://ut.rushbase.net/beyondunreal/mods/cbp2003.zip"
+SRC_URI="https://downloads.unrealadmin.org/UT2003/BonusPack/cbp2003.zip"
 
 LICENSE="ut2003"
 SLOT="1"
@@ -24,7 +24,7 @@ dir=${GAMES_PREFIX_OPT}/ut2003
 Ddir=${D}/${dir}
 
 src_unpack() {
-       unzip -qq "${DISTDIR}"/${A} || die
+       unpack_zip "${DISTDIR}"/${A}
 }
 
 src_install() {