net-libs/shairplay: New package needed by media-tv/kodi
authorfrace <frace@users.noreply.github.com>
Tue, 10 Jan 2017 19:31:01 +0000 (20:31 +0100)
committerDavid Seifert <soap@gentoo.org>
Mon, 23 Jan 2017 21:19:22 +0000 (22:19 +0100)
Gentoo-bug: 538932, 468558, 458734
Reported-by: hal
Closes: https://github.com/gentoo/gentoo/pull/3425

net-libs/shairplay/Manifest [new file with mode: 0644]
net-libs/shairplay/metadata.xml [new file with mode: 0644]
net-libs/shairplay/shairplay-0_pre20170118.ebuild [new file with mode: 0644]
net-libs/shairplay/shairplay-9999.ebuild [new file with mode: 0644]

diff --git a/net-libs/shairplay/Manifest b/net-libs/shairplay/Manifest
new file mode 100644 (file)
index 0000000..99819a2
--- /dev/null
@@ -0,0 +1 @@
+DIST shairplay-0_pre20170118.tar.gz 291352 SHA256 d748b4aaab634a4605d741ced15479da20f47027b8822404037706166366e3fe SHA512 05a8ac399659235e88d3b1a7fbe8364ba526881b24ee082c3b7a5709b9b63eac376071d44028e4758ab22ca56d30f8e996b12dc9d3bd99bd38fe453e00a4a18b WHIRLPOOL a196687ea5768c1897350f1b3ed7e0ea37b6a16c6472cbae5341187f2e83e75203f41a49f43b5ac0824014cdb9bbfd7c2425fd8beec0edaa991aca72e0286edd
diff --git a/net-libs/shairplay/metadata.xml b/net-libs/shairplay/metadata.xml
new file mode 100644 (file)
index 0000000..dc25248
--- /dev/null
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+    <longdescription>Apple airplay and raop protocol server</longdescription>
+    <use>
+        <flag name='alac'>Add support for Apple Lossless Audio Codec files</flag>
+        <flag name='static-libs'>Build static versions of dynamic libraries as well</flag>
+        <flag name='tools'>Build and install a binary shairplay in /usr/bin</flag>
+    </use>
+    <maintainer type="person">
+        <email>candrews@integralblue.com</email>
+        <name>Craig Andrews</name>
+    </maintainer>
+    <maintainer type="project">
+        <email>proxy-maint@gentoo.org</email>
+        <name>Proxy Maintainers</name>
+    </maintainer>
+    <upstream>
+        <bugs-to>https://github.com/juhovh/shairplay</bugs-to>
+        <remote-id type="github">juhovh/shairplay</remote-id>
+    </upstream>
+</pkgmetadata>
diff --git a/net-libs/shairplay/shairplay-0_pre20170118.ebuild b/net-libs/shairplay/shairplay-0_pre20170118.ebuild
new file mode 100644 (file)
index 0000000..6c6560a
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="git://github.com/juhovh/shairplay.git"
+else
+       EGIT_COMMIT="498bc5bcdd305e04721f94a04b9f26a7da72673f"
+       SRC_URI="https://github.com/juhovh/shairplay/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Apple airplay and raop protocol server"
+HOMEPAGE="https://github.com/juhovh/shairplay"
+LICENSE="BSD LGPL-2.1 MIT"
+
+SLOT="0"
+IUSE="alac static-libs tools"
+
+DEPEND="
+       tools? ( media-libs/libao )
+"
+
+RDEPEND="
+       alac? (
+               media-sound/alac_decoder
+               net-libs/shairplay[tools]
+       )
+       tools? (
+               dev-libs/openssl:0=
+               net-dns/avahi[mdnsresponder-compat]
+       )
+"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
diff --git a/net-libs/shairplay/shairplay-9999.ebuild b/net-libs/shairplay/shairplay-9999.ebuild
new file mode 100644 (file)
index 0000000..6c6560a
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="git://github.com/juhovh/shairplay.git"
+else
+       EGIT_COMMIT="498bc5bcdd305e04721f94a04b9f26a7da72673f"
+       SRC_URI="https://github.com/juhovh/shairplay/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Apple airplay and raop protocol server"
+HOMEPAGE="https://github.com/juhovh/shairplay"
+LICENSE="BSD LGPL-2.1 MIT"
+
+SLOT="0"
+IUSE="alac static-libs tools"
+
+DEPEND="
+       tools? ( media-libs/libao )
+"
+
+RDEPEND="
+       alac? (
+               media-sound/alac_decoder
+               net-libs/shairplay[tools]
+       )
+       tools? (
+               dev-libs/openssl:0=
+               net-dns/avahi[mdnsresponder-compat]
+       )
+"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}