dev-python/numpy-python2: Fix installing generated files
authorMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 11:51:04 +0000 (13:51 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 14:10:03 +0000 (16:10 +0200)
Closes: https://bugs.gentoo.org/717502
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/numpy-python2/numpy-python2-1.16.5-r1.ebuild [moved from dev-python/numpy-python2/numpy-python2-1.16.5.ebuild with 98% similarity]

similarity index 98%
rename from dev-python/numpy-python2/numpy-python2-1.16.5.ebuild
rename to dev-python/numpy-python2/numpy-python2-1.16.5-r1.ebuild
index b6c8b4fa6cf06362a36aa8c0817ad4af5fe3434f..1eb5f203c4feacc77eb2c79d2d46edba8a5f707d 100644 (file)
@@ -151,6 +151,8 @@ sys.exit(0 if r else 1)" || die "Tests fail with ${EPYTHON}"
 }
 
 python_install() {
+       # https://github.com/numpy/numpy/issues/16005
+       local mydistutilsargs=( build_src )
        distutils-r1_python_install ${NUMPY_FCONFIG}
        python_optimize
 }