dev-python/dataclasses: New package
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 08:24:32 +0000 (10:24 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 08:32:59 +0000 (10:32 +0200)
A backport of dataclasses module from Python 3.7, needed by wsproto.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/dataclasses/Manifest [new file with mode: 0644]
dev-python/dataclasses/dataclasses-0.7.ebuild [new file with mode: 0644]
dev-python/dataclasses/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/dataclasses/Manifest b/dev-python/dataclasses/Manifest
new file mode 100644 (file)
index 0000000..558e8a9
--- /dev/null
@@ -0,0 +1 @@
+DIST dataclasses-0.7.tar.gz 35690 BLAKE2B 8d3c60d1e2ad4c9ceb3c502fa74f8fdae75717e52c698984b6def96e867cae633864de711856a69992df6a207617d17d7116f5e0daa7d757076dc8b97d7e0e9b SHA512 ff921237a99bac21e091ff253824eb07eb09be7e7ec02b869da9c68c35141fc1bee526b3d2942963bac7762827438ea8fdc89fa72404991b78d1d063a3c18661
diff --git a/dev-python/dataclasses/dataclasses-0.7.ebuild b/dev-python/dataclasses/dataclasses-0.7.ebuild
new file mode 100644 (file)
index 0000000..fec19ca
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A backport of the dataclasses module for Python 3.6"
+HOMEPAGE="
+       https://pypi.org/project/dataclasses/
+       https://github.com/ericvsmith/dataclasses"
+SRC_URI="
+       mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_test() {
+       cd test || die
+       distutils-r1_src_test
+}
+
+distutils_enable_tests unittest
diff --git a/dev-python/dataclasses/metadata.xml b/dev-python/dataclasses/metadata.xml
new file mode 100644 (file)
index 0000000..266e3f1
--- /dev/null
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+</pkgmetadata>