media-sound/mps-youtube: update to EAPI 7 and add py37/py38 compat
authorTim Harder <radhermit@gentoo.org>
Fri, 31 Jan 2020 08:25:06 +0000 (01:25 -0700)
committerTim Harder <radhermit@gentoo.org>
Fri, 31 Jan 2020 08:30:27 +0000 (01:30 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
media-sound/mps-youtube/mps-youtube-0.2.8-r1.ebuild [new file with mode: 0644]
media-sound/mps-youtube/mps-youtube-9999.ebuild

diff --git a/media-sound/mps-youtube/mps-youtube-0.2.8-r1.ebuild b/media-sound/mps-youtube/mps-youtube-0.2.8-r1.ebuild
new file mode 100644 (file)
index 0000000..a86ede0
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/mps-youtube/mps-youtube.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Terminal-based YouTube player and downloader"
+HOMEPAGE="https://github.com/mps-youtube/mps-youtube https://pypi.org/project/mps-youtube/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+       dev-python/pafy[${PYTHON_USEDEP}]
+       virtual/ffmpeg
+       || ( media-video/mpv media-video/mplayer )
+"
index 7f9ca71d825c4c41a525665ffdd246bcdd28830a..a86ede03c873865487c8af03ce05ebdaba930434 100644 (file)
@@ -1,8 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
 inherit distutils-r1
 
 if [[ ${PV} == "9999" ]] ; then
@@ -19,8 +20,8 @@ HOMEPAGE="https://github.com/mps-youtube/mps-youtube https://pypi.org/project/mp
 LICENSE="GPL-3"
 SLOT="0"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
+RDEPEND="
        dev-python/pafy[${PYTHON_USEDEP}]
        virtual/ffmpeg
-       || ( media-video/mplayer media-video/mpv )"
+       || ( media-video/mpv media-video/mplayer )
+"