app-admin/puppet-agent: 6.11.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 22 Nov 2019 16:02:00 +0000 (10:02 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 22 Nov 2019 16:09:56 +0000 (10:09 -0600)
Package-Manager: Portage-2.3.76, Repoman-2.3.18
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-6.11.1.ebuild [new file with mode: 0644]

index ddeb97addf96f086daf656c93a3ac65b04d6711b..2641d910106a41018448e24b5504fb695eb8b741 100644 (file)
@@ -1,4 +1,6 @@
 DIST puppet-agent_6.10.1-1stretch_amd64.deb 19712026 BLAKE2B 82f5d9d18a3171b230d0e6027b9b8409b51096e12c5fd88844643320a0f5f654bc79880b35565571a6367a2d95f7a8f90ac811c2df1f1ec6c1866508c7e112e0 SHA512 8b289f8690fb67d353bc004a281e3e32a118048523bb6c743fa8ff46f2583c155ddffc22a7898662b598128f5ef75d77fd9a99b43c4afb72a23a2bfa3959f0c6
 DIST puppet-agent_6.10.1-1stretch_i386.deb 20055310 BLAKE2B 31bb9bd40f5098b666d911545b565654d84a422625536eff954256851089d211ea2660dbdab7b73df370efc0bbc41875617df3012ee734ec586af87967e8bc02 SHA512 33348839a245bcda4c76feae214d72bb36c1959c1b6f5f9c2db084ad1bb0018393ab6bd94e16ed987a23b2f253baf31f1df0453ead1cc6860941954ff31930c2
+DIST puppet-agent_6.11.1-1stretch_amd64.deb 19948710 BLAKE2B 256588922cfacb1d8146cd1142c43d893a55dfb67d7f70ca311df6178e7f9a82a0702d8306e0575d3f817e53c091fd3010027512cb4ce95956bdfa968372cc21 SHA512 90c39d55a8761185f82c9ac106d696ae48a170679e6043b6b3db32254e918b1b9c1b32c4e9721e5751189f84f002415f21a627daa22738a8c1ae3cb5df514eb3
+DIST puppet-agent_6.11.1-1stretch_i386.deb 20327410 BLAKE2B c2a105139df97395f54bb54d7ac971d914dcd3b69614dca55fe443d9fe5360118b899610a6d2d85b96b8b45715864df608d0783a3aabad3a2ae5555a0d510a2e SHA512 5d1173534beb53325d3c7c2fd500a7bd82a389fa8cbc9e867f6acbb6c2647190339d3b096e8a054aff268f27c5bd7de65c371a474b9c8263e8fa36bab75452bd
 DIST puppet-agent_6.9.0-1stretch_amd64.deb 19846122 BLAKE2B 7f9133d1f5cb85f45c96490c230ee0cfda707db390a3a39be218fcd730e2298099e6d70c4f44bb5c6af46736c2c8aa7906a16375088c0119045dc77b53343b91 SHA512 f96cb1a6108a21192493b7b9958243e537ab41ce3ab6a7dde4d12bcd5da25ec6a5b29632acb87c4e156256578e8348c6fdfe26043539292f98203cce69b04fff
 DIST puppet-agent_6.9.0-1stretch_i386.deb 20170516 BLAKE2B 391a61a847bc05f9f03885f2e2140ea42b4eeca247f3223f17a82d3ede2e1bbc88226f9794777f4b20e81943d94b11612f8d4ffd9f74c2f494bdc242fb05e1a1 SHA512 595dbe1591a8ee9d703a3efdf103a3095966b22cafd0fd63fb2a7b9274ea858b55d0b915ecc32e93c49bcbeba453654fc9126efe3855924fb5c5b6732e0af83d
diff --git a/app-admin/puppet-agent/puppet-agent-6.11.1.ebuild b/app-admin/puppet-agent/puppet-agent-6.11.1.ebuild
new file mode 100644 (file)
index 0000000..a72df73
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+       amd64? ( ${SRC_BASE}_amd64.deb )
+       x86?   ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+       !app-admin/puppet
+       !dev-ruby/hiera
+       !dev-ruby/facter
+       !app-emulation/virt-what"
+
+DEPEND="
+       ${CDEPEND}"
+RDEPEND="${CDEPEND}
+       app-portage/eix
+       sys-apps/dmidecode
+       sys-libs/glibc
+       sys-libs/readline:0/7
+       sys-libs/ncurses:0[tinfo]
+       selinux? (
+               sys-libs/libselinux[ruby]
+               sec-policy/selinux-puppet
+       )
+       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+       enewgroup puppet
+       enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+       # conf.d
+       doconfd etc/default/puppet
+       doconfd etc/default/pxp-agent
+       # logrotate.d
+       insinto /etc/logrotate.d
+       doins etc/logrotate.d/pxp-agent
+       # puppet itself
+       insinto /etc/puppetlabs
+       doins -r etc/puppetlabs/*
+       # logdir for systemd
+       dodir var/log/puppetlabs/puppet/
+       fperms 0750 var/log/puppetlabs/puppet/
+       # the rest
+       insinto /opt
+       dodir opt/puppetlabs/puppet/cache
+       doins -r opt/*
+       fperms 0750 /opt/puppetlabs/puppet/cache
+       # init
+       newinitd "${FILESDIR}/puppet.initd" puppet
+       systemd_dounit lib/systemd/system/puppet.service
+       systemd_dounit lib/systemd/system/pxp-agent.service
+       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+       # symlinks
+       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+       dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+       dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}