sci-geosciences/osm2pgsql: EAPI-7 bump, switch to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 12 Feb 2020 23:22:33 +0000 (00:22 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 12 Feb 2020 23:23:41 +0000 (00:23 +0100)
Bug: https://bugs.gentoo.org/688110
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild

index 990f5c9422a8fcd72b6a01c400da49db2b198199..26bab47005f2e7cfab09ab7c19cc10f30d753662 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit cmake-utils
+inherit cmake flag-o-matic
 
 DESCRIPTION="Converts OSM data to SQL and insert into PostgreSQL db"
 HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql
@@ -19,7 +19,7 @@ COMMON_DEPEND="
        app-arch/bzip2
        dev-db/postgresql:=
        dev-libs/expat
-       sci-libs/proj
+       sci-libs/proj:=
        sys-libs/zlib
        lua? ( dev-lang/lua:= )
 "
@@ -34,9 +34,10 @@ RDEPEND="${COMMON_DEPEND}
 RESTRICT="test"
 
 src_configure() {
+       append-cppflags -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1
        local mycmakeargs=(
                -DWITH_LUA=$(usex lua)
                -DBUILD_TESTS=OFF
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }