sys-apps/coreutils: Bump to version 8.32
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 5 Mar 2020 15:21:43 +0000 (16:21 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 5 Mar 2020 15:21:59 +0000 (16:21 +0100)
Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/coreutils/Manifest
sys-apps/coreutils/coreutils-8.32.ebuild [new file with mode: 0644]

index 9e4b4c1d5cdf1c613fbdb60015bae880e0688b38..587b6b33bc95498788a2a6ed278da53c14f16bdd 100644 (file)
@@ -1,3 +1,4 @@
 DIST coreutils-8.30-patches-01.tar.xz 5788 BLAKE2B a41511ce39ac570cb14b7f12d125eebef92217469a9490808719fa0665f5e5c0adb96fbd02c4bac4d280d1502295669575790a81dbc01afe2ca3a9d384cbefb0 SHA512 b1e1933637de4581d5f8c6ede4e80a012435d13f0cf5550a76ab5bbe9441e3c15ce19ef3f78a7ea3b8368d5e9a3bb17c1207c471d26171b59786f38adeba0454
 DIST coreutils-8.30.tar.xz 5359532 BLAKE2B b66ccd112a6c2c8b90e58ff1c3371e7f5827937035769329885e5bdae197466189f3715720b8f8cf0b5047fe16d6c86984dcee994117c2d3c7b8dbd597027255 SHA512 25bc132c0d89ce71c33e417f04649c9fcfce6c5ef8b19f093b2e9e2851bfde9b5a31e20499d9c427332228ba54b88d445ddb445551e1944bb8f5cbff5ffa4eda
 DIST coreutils-8.31.tar.xz 5410140 BLAKE2B e3ae6be8edbe9df9164b4c9ac8bf14dc23b147fa665f20669e18ac4c6e45ba839dc0dc99e05670eb006d22133475a4a717a5f40b00ebaedfd6e1fbab887674d5 SHA512 ef8941dae845bbf5ae5838bc49e44554a766302930601aada6fa594e8088f0fbad74e481ee392ff89633e68b99e4da3f761fcb5d31ee3b233d540fe2a2d4e1af
+DIST coreutils-8.32.tar.xz 5547836 BLAKE2B 0ad99c176c19ec214fcfd0845523e5362f0151827707c759bd46c0fe8d2501c6ad1c29c5b71266f6525857bc0d56c472db0d7fe29953b6c65e2e6c76bdf3c515 SHA512 1c8f3584efd61b4b02e7ac5db8e103b63cfb2063432caaf1e64cb2dcc56d8c657d1133bbf10bd41468d6a1f31142e6caa81d16ae68fa3e6e84075c253613a145
diff --git a/sys-apps/coreutils/coreutils-8.32.ebuild b/sys-apps/coreutils/coreutils-8.32.ebuild
new file mode 100644 (file)
index 0000000..e398ba4
--- /dev/null
@@ -0,0 +1,198 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit eutils flag-o-matic python-any-r1 toolchain-funcs
+
+PATCH="${PN}-8.30-patches-01"
+DESCRIPTION="Standard GNU utilities (chmod, cp, dd, ls, sort, tr, head, wc, who,...)"
+HOMEPAGE="https://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+       mirror://gentoo/${PATCH}.tar.xz
+       https://dev.gentoo.org/~polynomial-c/dist/${PATCH}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="acl caps gmp hostname kill multicall nls selinux +split-usr static test vanilla xattr"
+RESTRICT="!test? ( test )"
+
+LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
+       caps? ( sys-libs/libcap )
+       gmp? ( dev-libs/gmp:=[static-libs] )
+       xattr? ( sys-apps/attr[static-libs] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs]} )
+       selinux? ( sys-libs/libselinux )
+       nls? ( virtual/libintl )"
+DEPEND="
+       ${RDEPEND}
+       static? ( ${LIB_DEPEND} )
+"
+BDEPEND="
+       app-arch/xz-utils
+       test? (
+               dev-lang/perl
+               dev-perl/Expect
+               dev-util/strace
+               ${PYTHON_DEPS}
+               $(python_gen_any_dep 'dev-python/pyinotify[${PYTHON_USEDEP}]')
+       )
+"
+RDEPEND+="
+       hostname? ( !sys-apps/net-tools[hostname] )
+       kill? (
+               !sys-apps/util-linux[kill]
+               !sys-process/procps[kill]
+       )
+       !app-misc/realpath
+       !<sys-apps/util-linux-2.13
+       !<sys-apps/sandbox-2.10-r4
+       !sys-apps/stat
+       !net-mail/base64
+       !sys-apps/mktemp
+       !<app-forensics/tct-1.18-r1
+       !<net-fs/netatalk-2.0.3-r4"
+
+python_check_deps() {
+       has_version "dev-python/pyinotify[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+       if use test ; then
+               python-any-r1_pkg_setup
+       fi
+}
+
+src_prepare() {
+       if ! use vanilla ; then
+               eapply "${WORKDIR}"/patch/*.patch
+       fi
+
+       eapply_user
+
+       # Since we've patched many .c files, the make process will try to
+       # re-build the manpages by running `./bin --help`.  When doing a
+       # cross-compile, we can't do that since 'bin' isn't a native bin.
+       # Also, it's not like we changed the usage on any of these things,
+       # so let's just update the timestamps and skip the help2man step.
+       set -- man/*.x
+       touch ${@/%x/1}
+
+       # Avoid perl dep for compiled in dircolors default #348642
+       if ! has_version dev-lang/perl ; then
+               touch src/dircolors.h
+               touch ${@/%x/1}
+       fi
+}
+
+src_configure() {
+       local myconf=(
+               --with-packager="Gentoo"
+               --with-packager-version="${PVR} (p${PATCH_VER:-0})"
+               --with-packager-bug-reports="https://bugs.gentoo.org/"
+               --enable-install-program="arch,$(usev hostname),$(usev kill)"
+               --enable-no-install-program="groups,$(usev !hostname),$(usev !kill),su,uptime"
+               --enable-largefile
+               $(usex caps '' --disable-libcap)
+               $(use_enable nls)
+               $(use_enable acl)
+               $(use_enable multicall single-binary)
+               $(use_enable xattr)
+               $(use_with gmp)
+       )
+       if tc-is-cross-compiler && [[ ${CHOST} == *linux* ]] ; then
+               export fu_cv_sys_stat_statfs2_bsize=yes #311569
+               export gl_cv_func_realpath_works=yes #416629
+       fi
+
+       export gl_cv_func_mknod_works=yes #409919
+       use static && append-ldflags -static && sed -i '/elf_sys=yes/s:yes:no:' configure #321821
+       use selinux || export ac_cv_{header_selinux_{context,flash,selinux}_h,search_setfilecon}=no #301782
+       # kill/uptime - procps
+       # groups/su   - shadow
+       # hostname    - net-tools
+       econf "${myconf[@]}"
+}
+
+src_test() {
+       # Known to fail with FEATURES=usersandbox (bug #439574):
+       #   -  tests/du/long-from-unreadable.sh} (bug #413621)
+       #   -  tests/rm/deep-2.sh (bug #413621)
+       #   -  tests/dd/no-allocate.sh (bug #629660)
+       if has usersandbox ${FEATURES} ; then
+               ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+                       "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+       fi
+
+       # Non-root tests will fail if the full path isn't
+       # accessible to non-root users
+       chmod -R go-w "${WORKDIR}"
+       chmod a+rx "${WORKDIR}"
+
+       # coreutils tests like to do `mount` and such with temp dirs
+       # so make sure /etc/mtab is writable #265725
+       # make sure /dev/loop* can be mounted #269758
+       mkdir -p "${T}"/mount-wrappers || die
+       mkwrap() {
+               local w ww
+               for w in "${@}" ; do
+                       ww="${T}/mount-wrappers/${w}"
+                       cat <<-EOF > "${ww}"
+                               #!${EPREFIX}/bin/sh
+                               exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab:/dev/loop" $(type -P ${w}) "\$@"
+                       EOF
+                       chmod a+rx "${ww}"
+               done
+       }
+       mkwrap mount umount
+
+       addwrite /dev/full
+       #export RUN_EXPENSIVE_TESTS="yes"
+       #export FETISH_GROUPS="portage wheel"
+       env PATH="${T}/mount-wrappers:${PATH}" \
+       emake -j1 -k check
+}
+
+src_install() {
+       default
+
+       insinto /etc
+       newins src/dircolors.hin DIR_COLORS
+
+       if use split-usr ; then
+               cd "${ED}"/usr/bin || die
+               dodir /bin
+               # move critical binaries into /bin (required by FHS)
+               local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
+                          mkdir mknod mv pwd rm rmdir stty sync true uname"
+               mv ${fhs} ../../bin/ || die "could not move fhs bins"
+               if use hostname; then
+                       mv hostname ../../bin/ || die
+               fi
+               if use kill; then
+                       mv kill ../../bin/ || die
+               fi
+               # move critical binaries into /bin (common scripts)
+               # Why are these required for booting?
+               local com="basename chroot cut dir dirname du env expr head mkfifo
+                          mktemp readlink seq sleep sort tail touch tr tty vdir wc yes"
+               mv ${com} ../../bin/ || die "could not move common bins"
+               # create a symlink for uname in /usr/bin/ since autotools require it
+               # Other than uname, we need to figure out why we are
+               # creating symlinks for these in /usr/bin instead of leaving
+               # the files there in the first place.
+               local x
+               for x in ${com} uname ; do
+                       dosym ../../bin/${x} /usr/bin/${x}
+               done
+       fi
+}
+
+pkg_postinst() {
+       ewarn "Make sure you run 'hash -r' in your active shells."
+       ewarn "You should also re-source your shell settings for LS_COLORS"
+       ewarn "  changes, such as: source /etc/profile"
+}