dev-python/catkin_pkg: Remove argparse dep from setup.py
authorAlexis Ballier <aballier@gentoo.org>
Thu, 16 Feb 2017 04:12:59 +0000 (05:12 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 16 Feb 2017 04:31:42 +0000 (05:31 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild [moved from dev-python/catkin_pkg/catkin_pkg-0.3.1.ebuild with 93% similarity]
dev-python/catkin_pkg/catkin_pkg-9999.ebuild
dev-python/catkin_pkg/files/argparse.patch [new file with mode: 0644]

similarity index 93%
rename from dev-python/catkin_pkg/catkin_pkg-0.3.1.ebuild
rename to dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild
index fbc5d3f2d01cdaec8bf070399462ffab330d583a..ce8fd6d9c5b6ef08f07cf82b4abd4bc84b904541 100644 (file)
@@ -37,7 +37,7 @@ RDEPEND="
 DEPEND="${RDEPEND}
        test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
 "
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
 
 python_test() {
        nosetests -s --tests test || die
index fbc5d3f2d01cdaec8bf070399462ffab330d583a..ce8fd6d9c5b6ef08f07cf82b4abd4bc84b904541 100644 (file)
@@ -37,7 +37,7 @@ RDEPEND="
 DEPEND="${RDEPEND}
        test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
 "
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
 
 python_test() {
        nosetests -s --tests test || die
diff --git a/dev-python/catkin_pkg/files/argparse.patch b/dev-python/catkin_pkg/files/argparse.patch
new file mode 100644 (file)
index 0000000..f39df4a
--- /dev/null
@@ -0,0 +1,12 @@
+Index: catkin_pkg-0.3.1/setup.py
+===================================================================
+--- catkin_pkg-0.3.1.orig/setup.py
++++ catkin_pkg-0.3.1/setup.py
+@@ -31,7 +31,6 @@ kwargs = {
+     'long_description': 'Library for retrieving information about catkin packages.',
+     'license': 'BSD',
+     'install_requires': [
+-        'argparse',
+         'docutils',
+         'python-dateutil'
+     ],