dev-python/astroid: remove old
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 1 Feb 2019 03:06:23 +0000 (22:06 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 1 Feb 2019 03:06:26 +0000 (22:06 -0500)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/astroid/Manifest
dev-python/astroid/astroid-1.5.3.ebuild [deleted file]
dev-python/astroid/astroid-1.6.0.ebuild [deleted file]

index 15b5c0dc825b7ce049dc2355aabaccde68a613d8..0fe7fd2ed0bf148ec76fdb4101c8fc8c36931750 100644 (file)
@@ -1,5 +1,3 @@
 DIST astroid-1.4.8.tar.gz 184091 BLAKE2B 7180b98c757c8681dd0abaed1e79d2c58ce676aff07b539af8776d589ff23770335d0ba4ce5c9b3940b0428dd10174e7c6eff66aeb500e6ac561734e27975be0 SHA512 54bb20edf5518b417470a2d63210802b267fe727f9d30e1ac5000db00a7894739b1c4249468fb55df81b55d382f3a5bbe019876141f7ee4d94040fd699dc0c2c
-DIST astroid-1.5.3.tar.gz 240617 BLAKE2B 06b040fa83327a38ea23e4b09c4ae978b5953ac99a7fec4b7fabb8982e8bb8da3e2f4781654159aec9989b4c99a119e1116622fa75bd4cac63d6a5c8b34bbf31 SHA512 2a224d9bf8e41059a1316d80738cdc0f1e4c4e0f987baf3969710bae7192466b708c7942cd7e4eeccea55582ce70bb687c96b9e7dece3229ae4cffc558aa2319
-DIST astroid-1.6.0.tar.gz 255715 BLAKE2B 60fa855779428fb984eb450afd1e6869a98f82fb06786194993a5f4c878f25417cb91ef2c2cdc12da62cbfa68e2742f8ac29cbc7b7ef295ed60201c72b562668 SHA512 6a384b2bd3b4ee686c2f9a69d10f4391e5950869d75808312b2715a620ba7caa706bd88a5e021ea2250cf16ff8013cf0b332faee0b07dd7b5e1baf11e65d0ac3
 DIST astroid-1.6.5.tar.gz 255688 BLAKE2B 7547e4c537f73ef77b61fba1ab8640c7cd50014ae52e4e4b8f8209a000c55bbdbb1ddcd3fb90d078f99a34d4a4779adabc8ad71af40c3a4547fe3e0d814b328c SHA512 f51f275c9f04809c8993d187cb62fadc84003ddc954d371356474dbe6b719868406fd9188c560f5b658b8b44bb6a4d3ee0785e809e789ca117e2bcbdb58aec53
 DIST astroid-2.1.0.tar.gz 276196 BLAKE2B f09ef4629bb29d0492f1f6ddafd1c0f4d4ef09df5612f3a9a811b09dec7a8c6294a44458e79223232f467a70434022cc23b4745515199beaf4727bd0591bccb3 SHA512 ca200d51613782a85c3f164e9ef55bac1de288c45e7662645ef080cc84a88e34499b2a924b130e9215418842c25352bb948c02d569ac45c251ac37bc57f0dcd8
diff --git a/dev-python/astroid/astroid-1.5.3.ebuild b/dev-python/astroid/astroid-1.5.3.ebuild
deleted file mode 100644 (file)
index b250c9a..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://bitbucket.org/logilab/astroid https://pypi.org/project/astroid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND="
-       dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/wrapt[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       virtual/python-singledispatch[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python*')
-               >=dev-python/pylint-1.6.0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/python-dateutil[${PYTHON_USEDEP}]
-       )"
-
-python_prepare_all() {
-       # Disable failing tests
-       # TODO: investigate if it's our fault and how can we fix it
-       sed -i -e "s/test_namespace_package_pth_support/_&/" \
-               astroid/tests/unittest_manager.py || die
-       # we hack xml module, so it does not match what they expect...
-       sed -i -e "s/test_module_model/_&/" \
-               astroid/tests/unittest_object_model.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       ${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
-}
diff --git a/dev-python/astroid/astroid-1.6.0.ebuild b/dev-python/astroid/astroid-1.6.0.ebuild
deleted file mode 100644 (file)
index 8d1dd59..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND="
-       dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/wrapt[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       virtual/python-singledispatch[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python*')
-               >=dev-python/pylint-1.6.0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/python-dateutil[${PYTHON_USEDEP}]
-       )"
-
-python_prepare_all() {
-       # Disable failing tests
-       # TODO: investigate if it's our fault and how can we fix it
-       sed -i -e "s/test_namespace_package_pth_support/_&/" \
-               astroid/tests/unittest_manager.py || die
-       # we hack xml module, so it does not match what they expect...
-       sed -i -e "s/test_module_model/_&/" \
-               astroid/tests/unittest_object_model.py || die
-
-       # no idea why this test fails
-       sed -i -e "s/test_namespace_and_file_mismatch/_&/" \
-               astroid/tests/unittest_manager.py || die
-
-       # and this test works yet it shouldn't
-       sed -i -e "s#test_object_dunder_new_is_inferred_if_decorator#_&#" \
-               astroid/tests/unittest_inference.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       ${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
-}