2.0.8 version bump
authorMarcelo Góes <vanquirius@gentoo.org>
Sun, 10 Dec 2006 03:51:35 +0000 (03:51 +0000)
committerMarcelo Góes <vanquirius@gentoo.org>
Sun, 10 Dec 2006 03:51:35 +0000 (03:51 +0000)
Package-Manager: portage-2.1.1-r2

net-analyzer/p0f/ChangeLog
net-analyzer/p0f/files/digest-p0f-2.0.8 [new file with mode: 0644]
net-analyzer/p0f/p0f-2.0.8.ebuild [new file with mode: 0644]

index eb3d611d12c162ffef8e948324740da9b8eb0c7f..3a44321a7f7e98a11ef5a2380a5c3429b7fba67a 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-analyzer/p0f
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.27 2006/07/09 22:11:11 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.28 2006/12/10 03:51:35 vanquirius Exp $
+
+*p0f-2.0.8 (10 Dec 2006)
+
+  10 Dec 2006; Marcelo Goes <vanquirius@gentoo.org> -p0f-2.0.5-r1.ebuild,
+  +p0f-2.0.8.ebuild:
+  2.0.8 version bump.
 
 *p0f-2.0.6 (09 Jul 2006)
 
diff --git a/net-analyzer/p0f/files/digest-p0f-2.0.8 b/net-analyzer/p0f/files/digest-p0f-2.0.8
new file mode 100644 (file)
index 0000000..19fcdf2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 1ccbcd8d4c95ef6dae841120d23c56a5 p0f-2.0.8.tgz 136877
+RMD160 87d5b30d2d5e156b9fdcb026160155f413ce13d3 p0f-2.0.8.tgz 136877
+SHA256 6c4d8745f04e59f2ba68d56fd1554551592f08a0497c9fc21b84498f47d1aee0 p0f-2.0.8.tgz 136877
diff --git a/net-analyzer/p0f/p0f-2.0.8.ebuild b/net-analyzer/p0f/p0f-2.0.8.ebuild
new file mode 100644 (file)
index 0000000..9be6be0
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.8.ebuild,v 1.1 2006/12/10 03:51:35 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="p0f performs passive OS detection based on SYN packets."
+HOMEPAGE="http://lcamtuf.coredump.cx/p0f.shtml"
+SRC_URI="http://lcamtuf.coredump.cx/p0f/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="static"
+
+DEPEND="net-libs/libpcap"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+       unpack ${A} && cd ${S}
+       sed -i 's;#include <net/bpf.h>;;' p0f.c || die "sed p0f.c failed"
+       sed -i -e 's|^\(all: $(FILE)\).*$|\1|' \
+               -e "s|^\(CFLAGS.*=\).*$|\1${CFLAGS}|" mk/* || die "sed makefiles failed"
+}
+
+src_compile() {
+       local static
+       use static && static="static"
+       emake ${static} || die "emake ${static} failed"
+       emake ${static} p0fq || die "emake ${static} p0fq failed"
+}
+
+src_install () {
+       use static && mv p0f-static p0f
+       dosbin p0f p0frep test/p0fq || die
+
+       insinto /etc/p0f
+       doins p0f.fp p0fa.fp p0fr.fp
+
+       doman p0f.1 || die
+       cd doc
+       dodoc ChangeLog CREDITS KNOWN_BUGS README TODO
+
+       newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+       newinitd "${FILESDIR}"/${PN}.initd2 ${PN} || die "newinitd failed"
+}
+
+pkg_postinst(){
+       einfo "Adjust /etc/conf.d/p0f to your liking before using the"
+       einfo "init script. For more information on options, read man p0f."
+}