dev-db/sqlitebrowser: Handling test dependency correctly
authorRodrigo Saboya <saboya@gmail.com>
Wed, 16 Oct 2019 17:40:39 +0000 (14:40 -0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 17 Oct 2019 04:51:17 +0000 (07:51 +0300)
Changed in: https://github.com/sqlitebrowser/sqlitebrowser/pull/1419/files

Closes: https://bugs.gentoo.org/683666
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Rodrigo Saboya <saboya@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13064
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-db/sqlitebrowser/sqlitebrowser-3.11.1-r1.ebuild

index c763fd949dcae66cabe150b1f378cfa0afababe8..937429c32f8448e6c5432359acb7b485edfa88f6 100644 (file)
@@ -48,7 +48,8 @@ src_prepare() {
        sed -e "/^project/ s/\".*\"/sqlitebrowser/" -i CMakeLists.txt || die
 
        if ! use test; then
-               sed -e "/qt5_use_modules/ s/ Test//" -i CMakeLists.txt || die
+               sed -e "/find_package/ s/ Test//" -i CMakeLists.txt || die
+               sed -e "/set/ s/ Qt5::Test//" -i CMakeLists.txt || die
        fi
 }