dev-lang/python: Revert "Bump 2.7.17 to EAPI 7, unify"
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Dec 2019 10:12:43 +0000 (11:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Dec 2019 10:13:11 +0000 (11:13 +0100)
Accidentally mixed two commits.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/python/Manifest
dev-lang/python/python-2.7.17-r1.ebuild [deleted file]
dev-lang/python/python-3.6.10.ebuild

index c974616a85a7fc686c83d98b66bd4ba95532c9ba..7165b0d55c12fa71631bb8b817c90a44cc4c270c 100644 (file)
@@ -10,7 +10,6 @@ DIST Python-3.8.1.tar.xz 17828408 BLAKE2B db1841625de89b812cadcd538a990401a4e49d
 DIST python-gentoo-patches-2.7.16.tar.xz 13904 BLAKE2B 218b46f8656f4a792dcd47eabca6d59a1558276b77676544991ee75914cd76dda84c36f43e72e477b850dd4cb52374d289f20dccd244a3b52ae5debaf3363432 SHA512 83f90545231c663a34c6925352a357a2b15997ac0362578a1893304c5070b5251922585ae8bc1bafb68d306bcddd4cdba4b6406648d473bd3e980eef65fe3ecd
 DIST python-gentoo-patches-2.7.17.tar.xz 13476 BLAKE2B 788688e2941d2d6d4f768168881b2c3639213a97e214557b3a93f8db44d81e2b6d70be847b7462e54e3786660ebee4ee331402081d92167d74ad149279c3f389 SHA512 1641737635d33607a77ed2ee2462854cec603be39737de3f81abb188702aaf46f039d1616f9dcd413da1f4a8040175c66a2883e496132c2e4ebe8f860b36f9f1
 DIST python-gentoo-patches-3.5.4-0.tar.xz 11704 BLAKE2B 4a7d71feff18c7c8c109bed10748348484d314183c3de3ec950d5ca5ce7048bb322c470f3f5bff2d63eb7f2ed99c0fe75c621df050273d9d118681b28926061d SHA512 d395a87695f700598026038d6929ea5038abd7d494294037a4dfa02d5262203dbbaa6ae258a5a7f35ff5542f6266dcf69cc0b9c3df2a047cd2f6699a87e182ec
-DIST python-gentoo-patches-3.6.10.tar.xz 10964 BLAKE2B e32c8cb3050c7324ee234f585be7fc40cfacc6ad87759eaa300e57289e6dc6cbaed3913f33ad632b8754638e8d71983d8364ceeaad8ef325cfa6d4d2dfb56df0 SHA512 71fea7306c876c63888c4547eaf14dc2e0413dec343609d748cd1b5888e4605d47888758ebc5120a287ce833b69dd538073f91989460da7c40462b53eefca7ce
 DIST python-gentoo-patches-3.6.8.tar.xz 11224 BLAKE2B 5fe38282bcf28df18e0bd37756c880ae191ea738dc92f1cf83f682cfdc52525b9c44287dc99191a73d75c90672ab501b56adf49515b35ff1fdee88c8dc07b175 SHA512 89e700663db25d6d78eee1d4bfdab686c5341a794062f3a63df3485ac0b58deb4b4885d24701f3ae138d06ca783be92e310e1100c6d633910c33732f3cb0d7df
 DIST python-gentoo-patches-3.7.4-1.tar.xz 10100 BLAKE2B 63e8fada89b64b59ba083745626a1e8a07bec0cf93b7b6ab405c33a0f2932cbe497a331c52895a07f10434b230c438f27c9582efecdd57f3bad15d9aa604d157 SHA512 11b0e811a9890a1235c85426061b35f9964eba64cac0536f4c9e0498b1cc66eb005f14aed34eead735b43e91c2b5babced60e3310f5329231a1706871b95b547
 DIST python-gentoo-patches-3.7.6.tar.xz 10084 BLAKE2B 220869e85bdaf9c21b1b05e13803bdb6ecc22ac0f69da77e57fd7c1cd93ef45ec43401b62732842e1bb3467feb6d65c8204120e2741e9eb6f4cab673fd3a8d62 SHA512 4c04b0cf7da55fa7973ab178e3ac2c59bc2142924bdced5954c058053280b6c663d7c39912286d10fe0e82ca30af6a0dd6a56fa85433f836217ca3dcbb284def
diff --git a/dev-lang/python/python-2.7.17-r1.ebuild b/dev-lang/python/python-2.7.17-r1.ebuild
deleted file mode 100644 (file)
index 424cdec..0000000
+++ /dev/null
@@ -1,368 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-WANT_LIBTOOL="none"
-
-inherit autotools flag-o-matic pax-utils python-utils-r1 toolchain-funcs
-
-MY_P="Python-${PV}"
-PYVER=$(ver_cut 1-2)
-PATCHSET_VERSION="2.7.17"
-
-DESCRIPTION="An interpreted, interactive, object-oriented programming language"
-HOMEPAGE="https://www.python.org/"
-SRC_URI="https://www.python.org/ftp/python/${PV}/${MY_P}.tar.xz
-       https://dev.gentoo.org/~mgorny/dist/python-gentoo-patches-${PATCHSET_VERSION}.tar.xz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="PSF-2"
-SLOT="${PYVER}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="-berkdb bluetooth build elibc_uclibc examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
-
-# Do not add a dependency on dev-lang/python to this ebuild.
-# If you need to apply a patch which requires python for bootstrapping, please
-# run the bootstrap code on your dev box and include the results in the
-# patchset. See bug 447752.
-
-RDEPEND="app-arch/bzip2:=
-       >=sys-libs/zlib-1.1.3:=
-       virtual/libffi:=
-       virtual/libintl
-       berkdb? ( || (
-               sys-libs/db:5.3
-               sys-libs/db:5.1
-               sys-libs/db:4.8
-               sys-libs/db:4.7
-               sys-libs/db:4.6
-               sys-libs/db:4.5
-               sys-libs/db:4.4
-               sys-libs/db:4.3
-               sys-libs/db:4.2
-       ) )
-       gdbm? ( sys-libs/gdbm:=[berkdb] )
-       ncurses? ( >=sys-libs/ncurses-5.2:= )
-       readline? ( >=sys-libs/readline-4.1:= )
-       sqlite? ( >=dev-db/sqlite-3.3.8:3= )
-       ssl? (
-               !libressl? ( dev-libs/openssl:= )
-               libressl? ( dev-libs/libressl:= )
-       )
-       tk? (
-               >=dev-lang/tcl-8.0:=
-               >=dev-lang/tk-8.0:=
-               dev-tcltk/blt:=
-               dev-tcltk/tix
-       )
-       xml? ( >=dev-libs/expat-2.1:= )"
-# bluetooth requires headers from bluez
-DEPEND="${RDEPEND}
-       bluetooth? ( net-wireless/bluez )
-       virtual/pkgconfig
-       !sys-devel/gcc[libffi(-)]"
-RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1"
-
-pkg_setup() {
-       if use berkdb; then
-               ewarn "'bsddb' module is out-of-date and no longer maintained inside"
-               ewarn "dev-lang/python. 'bsddb' and 'dbhash' modules have been additionally"
-               ewarn "removed in Python 3. A maintained alternative of 'bsddb3' module"
-               ewarn "is provided by dev-python/bsddb3."
-       else
-               if has_version "=${CATEGORY}/${PN}-${PV%%.*}*[berkdb]"; then
-                       ewarn "You are migrating from =${CATEGORY}/${PN}-${PV%%.*}*[berkdb]"
-                       ewarn "to =${CATEGORY}/${PN}-${PV%%.*}*[-berkdb]."
-                       ewarn "You might need to migrate your databases."
-               fi
-       fi
-}
-
-src_prepare() {
-       # Ensure that internal copies of expat, libffi and zlib are not used.
-       rm -fr Modules/expat || die
-       rm -fr Modules/_ctypes/libffi* || die
-       rm -fr Modules/zlib || die
-
-       local PATCHES=(
-               "${WORKDIR}/patches"
-               # Fix for cross-compiling.
-               "${FILESDIR}/python-2.7.5-nonfatal-compileall.patch"
-               "${FILESDIR}/python-2.7.9-ncurses-pkg-config.patch"
-               "${FILESDIR}/python-2.7.10-cross-compile-warn-test.patch"
-               "${FILESDIR}/python-2.7.10-system-libffi.patch"
-       )
-
-       default
-
-       sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
-               Lib/distutils/command/install.py \
-               Lib/distutils/sysconfig.py \
-               Lib/site.py \
-               Lib/sysconfig.py \
-               Lib/test/test_site.py \
-               Makefile.pre.in \
-               Modules/Setup.dist \
-               Modules/getpath.c \
-               setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
-
-       eautoreconf
-}
-
-src_configure() {
-       # dbm module can be linked against berkdb or gdbm.
-       # Defaults to gdbm when both are enabled, #204343.
-       local disable
-       use berkdb    || use gdbm || disable+=" dbm"
-       use berkdb    || disable+=" _bsddb"
-       # disable automagic bluetooth headers detection
-       use bluetooth || export ac_cv_header_bluetooth_bluetooth_h=no
-       use gdbm      || disable+=" gdbm"
-       use ncurses   || disable+=" _curses _curses_panel"
-       use readline  || disable+=" readline"
-       use sqlite    || disable+=" _sqlite3"
-       use ssl       || export PYTHON_DISABLE_SSL="1"
-       use tk        || disable+=" _tkinter"
-       use xml       || disable+=" _elementtree pyexpat" # _elementtree uses pyexpat.
-       export PYTHON_DISABLE_MODULES="${disable}"
-
-       if ! use xml; then
-               ewarn "You have configured Python without XML support."
-               ewarn "This is NOT a recommended configuration as you"
-               ewarn "may face problems parsing any XML documents."
-       fi
-
-       if [[ -n "${PYTHON_DISABLE_MODULES}" ]]; then
-               einfo "Disabled modules: ${PYTHON_DISABLE_MODULES}"
-       fi
-
-       if [[ "$(gcc-major-version)" -ge 4 ]]; then
-               append-flags -fwrapv
-       fi
-
-       filter-flags -malign-double
-
-       # https://bugs.gentoo.org/show_bug.cgi?id=50309
-       if is-flagq -O3; then
-               is-flagq -fstack-protector-all && replace-flags -O3 -O2
-               use hardened && replace-flags -O3 -O2
-       fi
-
-       if tc-is-cross-compiler; then
-               # Force some tests that try to poke fs paths.
-               export ac_cv_file__dev_ptc=no
-               export ac_cv_file__dev_ptmx=yes
-       fi
-
-       # Export CXX so it ends up in /usr/lib/python2.X/config/Makefile.
-       tc-export CXX
-       # The configure script fails to use pkg-config correctly.
-       # http://bugs.python.org/issue15506
-       export ac_cv_path_PKG_CONFIG=$(tc-getPKG_CONFIG)
-
-       # Set LDFLAGS so we link modules with -lpython2.7 correctly.
-       # Needed on FreeBSD unless Python 2.7 is already installed.
-       # Please query BSD team before removing this!
-       append-ldflags "-L."
-
-       local dbmliborder
-       if use gdbm; then
-               dbmliborder+="${dbmliborder:+:}gdbm"
-       fi
-       if use berkdb; then
-               dbmliborder+="${dbmliborder:+:}bdb"
-       fi
-
-       local myeconfargs=(
-               # The check is broken on clang, and gives false positive:
-               # https://bugs.gentoo.org/596798
-               # (upstream dropped this flag in 3.2a4 anyway)
-               ac_cv_opt_olimit_ok=no
-
-               --with-fpectl
-               --enable-shared
-               $(use_enable ipv6)
-               $(use_with threads)
-               $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2")
-               --infodir='${prefix}/share/info'
-               --mandir='${prefix}/share/man'
-               --with-computed-gotos
-               --with-dbmliborder="${dbmliborder}"
-               --with-libc=
-               --enable-loadable-sqlite-extensions
-               --with-system-expat
-               --with-system-ffi
-               --without-ensurepip
-       )
-
-       OPT="" econf "${myeconfargs[@]}"
-
-       if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
-               eerror "configure has detected that the sem_open function is broken."
-               eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
-               die "Broken sem_open function (bug 496328)"
-       fi
-}
-
-src_compile() {
-       # Ensure sed works as expected
-       # https://bugs.gentoo.org/594768
-       local -x LC_ALL=C
-
-       # Avoid invoking pgen for cross-compiles.
-       touch Include/graminit.h Python/graminit.c
-
-       emake
-
-       # Work around bug 329499. See also bug 413751 and 457194.
-       if has_version dev-libs/libffi[pax_kernel]; then
-               pax-mark E python
-       else
-               pax-mark m python
-       fi
-}
-
-src_test() {
-       # Tests will not work when cross compiling.
-       if tc-is-cross-compiler; then
-               elog "Disabling tests due to crosscompiling."
-               return
-       fi
-
-       # Skip failing tests.
-       local skipped_tests="distutils gdb"
-
-       for test in ${skipped_tests}; do
-               mv "${S}"/Lib/test/test_${test}.py "${T}"
-       done
-
-       # bug 660358
-       local -x COLUMNS=80
-
-       # Daylight saving time problem
-       # https://bugs.python.org/issue22067
-       # https://bugs.gentoo.org/610628
-       local -x TZ=UTC
-
-       # Rerun failed tests in verbose mode (regrtest -w).
-       emake test EXTRATESTOPTS="-w" < /dev/tty
-       local result="$?"
-
-       for test in ${skipped_tests}; do
-               mv "${T}/test_${test}.py" "${S}"/Lib/test
-       done
-
-       elog "The following tests have been skipped:"
-       for test in ${skipped_tests}; do
-               elog "test_${test}.py"
-       done
-
-       elog "If you would like to run them, you may:"
-       elog "cd '${EPREFIX}/usr/$(get_libdir)/python${PYVER}/test'"
-       elog "and run the tests separately."
-
-       if [[ ${result} -ne 0 ]]; then
-               die "emake test failed"
-       fi
-}
-
-src_install() {
-       local libdir=${ED}/usr/$(get_libdir)/python${PYVER}
-
-       emake DESTDIR="${D}" altinstall
-
-       sed -e "s/\(LDFLAGS=\).*/\1/" -i "${libdir}/config/Makefile" || die
-
-       # Fix collisions between different slots of Python.
-       mv "${ED}/usr/bin/2to3" "${ED}/usr/bin/2to3-${PYVER}" || die
-       mv "${ED}/usr/bin/pydoc" "${ED}/usr/bin/pydoc${PYVER}" || die
-       mv "${ED}/usr/bin/idle" "${ED}/usr/bin/idle${PYVER}" || die
-       rm "${ED}/usr/bin/smtpd.py" || die
-
-       use berkdb || rm -r "${libdir}/"{bsddb,dbhash.py*,test/test_bsddb*} || die
-       use sqlite || rm -r "${libdir}/"{sqlite3,test/test_sqlite*} || die
-       use tk || rm -r "${ED}/usr/bin/idle${PYVER}" "${libdir}/"{idlelib,lib-tk} || die
-       use elibc_uclibc && rm -fr "${libdir}/"{bsddb/test,test}
-
-       use threads || rm -r "${libdir}/multiprocessing" || die
-       use wininst || rm "${libdir}/distutils/command/"wininst-*.exe || die
-
-       dodoc Misc/{ACKS,HISTORY,NEWS}
-
-       if use examples; then
-               docinto examples
-               dodoc -r Tools
-       fi
-       insinto /usr/share/gdb/auto-load/usr/$(get_libdir) #443510
-       local libname=$(printf 'e:\n\t@echo $(INSTSONAME)\ninclude Makefile\n' | \
-               emake --no-print-directory -s -f - 2>/dev/null)
-       newins "${S}"/Tools/gdb/libpython.py "${libname}"-gdb.py
-
-       newconfd "${FILESDIR}/pydoc.conf" pydoc-${PYVER}
-       newinitd "${FILESDIR}/pydoc.init" pydoc-${PYVER}
-       sed \
-               -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${PYVER/./_}_PORT:" \
-               -e "s:@PYDOC@:pydoc${PYVER}:" \
-               -i "${ED}/etc/conf.d/pydoc-${PYVER}" \
-               "${ED}/etc/init.d/pydoc-${PYVER}" || die "sed failed"
-
-       # for python-exec
-       local vars=( EPYTHON PYTHON_SITEDIR PYTHON_SCRIPTDIR )
-
-       # if not using a cross-compiler, use the fresh binary
-       if ! tc-is-cross-compiler; then
-               local -x PYTHON=./python
-               local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}${PWD}
-       else
-               vars=( PYTHON "${vars[@]}" )
-       fi
-
-       python_export "python${PYVER}" "${vars[@]}"
-       echo "EPYTHON='${EPYTHON}'" > epython.py || die
-       python_domodule epython.py
-
-       # python-exec wrapping support
-       local pymajor=${PYVER%.*}
-       mkdir -p "${D}${PYTHON_SCRIPTDIR}" || die
-       # python and pythonX
-       ln -s "../../../bin/python${PYVER}" \
-               "${D}${PYTHON_SCRIPTDIR}/python${pymajor}" || die
-       ln -s "python${pymajor}" "${D}${PYTHON_SCRIPTDIR}/python" || die
-       # python-config and pythonX-config
-       ln -s "../../../bin/python${PYVER}-config" \
-               "${D}${PYTHON_SCRIPTDIR}/python${pymajor}-config" || die
-       ln -s "python${pymajor}-config" \
-               "${D}${PYTHON_SCRIPTDIR}/python-config" || die
-       # 2to3, pydoc, pyvenv
-       ln -s "../../../bin/2to3-${PYVER}" \
-               "${D}${PYTHON_SCRIPTDIR}/2to3" || die
-       ln -s "../../../bin/pydoc${PYVER}" \
-               "${D}${PYTHON_SCRIPTDIR}/pydoc" || die
-       # idle
-       if use tk; then
-               ln -s "../../../bin/idle${PYVER}" \
-                       "${D}${PYTHON_SCRIPTDIR}/idle" || die
-       fi
-}
-
-eselect_python_update() {
-       if [[ -z "$(eselect python show)" || \
-                       ! -f "${EROOT}/usr/bin/$(eselect python show)" ]]; then
-               eselect python update
-       fi
-
-       if [[ -z "$(eselect python show --python${PV%%.*})" || \
-                       ! -f "${EROOT}/usr/bin/$(eselect python show --python${PV%%.*})" ]]
-       then
-               eselect python update --python${PV%%.*}
-       fi
-}
-
-pkg_postinst() {
-       eselect_python_update
-}
-
-pkg_postrm() {
-       eselect_python_update
-}
index 43dc80e812fe69f1147fd5f89f372dc552af3631..c0c1738557fb04245bdecdd946822e15e07be1dc 100644 (file)
@@ -8,12 +8,12 @@ inherit autotools flag-o-matic pax-utils python-utils-r1 toolchain-funcs
 
 MY_P="Python-${PV}"
 PYVER=$(ver_cut 1-2)
-PATCHSET="python-gentoo-patches-3.6.10"
+PATCHSET_VERSION="3.6.8"
 
 DESCRIPTION="An interpreted, interactive, object-oriented programming language"
 HOMEPAGE="https://www.python.org/"
 SRC_URI="https://www.python.org/ftp/python/${PV}/${MY_P}.tar.xz
-       https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz"
+       https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${PATCHSET_VERSION}.tar.xz"
 S="${WORKDIR}/${MY_P}"
 
 LICENSE="PSF-2"
@@ -63,7 +63,7 @@ src_prepare() {
        rm -fr Modules/zlib || die
 
        local PATCHES=(
-               "${WORKDIR}/${PATCHSET}"
+               "${WORKDIR}/patches"
        )
 
        default