media-sound/musescore: Fix build with Qt 5.11
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Aug 2018 21:24:14 +0000 (23:24 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Aug 2018 22:02:02 +0000 (00:02 +0200)
Closes: https://bugs.gentoo.org/661784
Package-Manager: Portage-2.3.46, Repoman-2.3.10

media-sound/musescore/files/musescore-2.1.0-qt-5.11.patch [new file with mode: 0644]
media-sound/musescore/musescore-2.1.0.ebuild

diff --git a/media-sound/musescore/files/musescore-2.1.0-qt-5.11.patch b/media-sound/musescore/files/musescore-2.1.0-qt-5.11.patch
new file mode 100644 (file)
index 0000000..0993206
--- /dev/null
@@ -0,0 +1,21 @@
+From 9c8a8ffe0cbb00ee93a10fe245da01a4d32ca086 Mon Sep 17 00:00:00 2001
+From: Orcan Ogetbil <orcan@localhost.localdomain>
+Date: Thu, 31 May 2018 21:04:51 -0400
+Subject: [PATCH] added missing #include <QButtonGroup> required by qt >= 5.11
+
+---
+ all.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/all.h b/all.h
+index 72db72b0ec..2ee0e8e807 100644
+--- a/all.h
++++ b/all.h
+@@ -131,6 +131,7 @@
+ #include <QProgressBar>
+ #include <QProgressDialog>
+ #include <QRadioButton>
++#include <QButtonGroup>
+ #include <QSplashScreen>
+ #include <QFontComboBox>
+ #include <QApplication>
\ No newline at end of file
index c5eb58ccd82440e413ee6b906c9d3a53c65a40b1..71798fdc8e9b290fe07bf706632928b36b34c8bb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -41,9 +41,12 @@ DEPEND="${RDEPEND}
        dev-qt/linguist-tools:5
        virtual/pkgconfig
        "
+
 PATCHES=(
        "${WORKDIR}/${PN}-2.1.0-fix-buildsystem.patch"
+       "${FILESDIR}/${PN}-2.1.0-qt-5.11.patch"
 )
+
 S="${WORKDIR}/MuseScore-${PV}"
 
 src_configure() {