sys-apps/install-xattr: version bump to 0.6, address bug #681866
authorAnthony G. Basile <blueness@gentoo.org>
Sat, 30 Mar 2019 10:22:43 +0000 (06:22 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sat, 30 Mar 2019 10:22:43 +0000 (06:22 -0400)
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

sys-apps/install-xattr/Manifest
sys-apps/install-xattr/install-xattr-0.6.ebuild [new file with mode: 0644]
sys-apps/install-xattr/install-xattr-9999.ebuild

index 384a60d13cc601fa733fe449b4967b21a66e6aac..d3a88c6c472308d3115e11e34a27115ee402f57e 100644 (file)
@@ -1 +1,2 @@
 DIST install-xattr-0.5.tar.bz2 16136 BLAKE2B 8973584d4819b9f500dcfb76ed0eaddce725b78e72dfa73ccff52c745e6f041926f8f930e5c5035fa888402c6b530207546098864266268dee2c897404bf7c74 SHA512 0bbde3a548fc5062041b38f90ac09c402f3cb0aebf4f0c331552fc44d39dd3d5e4d73bca0811de36c53af8afa5d22e543a7c90107d272f2a1b97c819b244eb7c
+DIST install-xattr-0.6.tar.bz2 16207 BLAKE2B 2f771aa3e81d594eda951ae34242ecf658e18d72f2cb4c8540ab8af40af750e50ad881c44476af84bb05c3ced9df052f08ea8f81ce490f250010e74b190bd1d9 SHA512 1af66ac8ea05b4c32b905f5d5e340e0402fd19d9f5c2fa51c32d0842effafded8327fce58adffdd197b47c0d4d90f8b669c309f512b64e90f86adc7afe995bcf
diff --git a/sys-apps/install-xattr/install-xattr-0.6.ebuild b/sys-apps/install-xattr/install-xattr-0.6.ebuild
new file mode 100644 (file)
index 0000000..2da2f96
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
+HOMEPAGE="https://dev.gentoo.org/~blueness/install-xattr/"
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+       inherit git-r3
+else
+       SRC_URI="https://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+       S=${WORKDIR}/${PN}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+       default
+       tc-export CC
+       append-cppflags "-D_FILE_OFFSET_BITS=64"
+}
+
+src_compile() {
+       if [[ ${PV} == "9999" ]] ; then
+               cd "${WORKDIR}/${P}/misc/${PN}" || die
+       fi
+       default
+}
+
+src_install() {
+       if [[ ${PV} == "9999" ]] ; then
+               cd "${WORKDIR}/${P}/misc/${PN}" || die
+       fi
+       DESTDIR=${ED} emake install
+}
+
+# We need to fix how tests are done
+src_test() {
+       true
+}
index 830b2d6cd4f93d94f3423e4824ce2e6c3d44dcc7..2da2f9601445976f2911d45fd76ec329d742564f 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
 HOMEPAGE="https://dev.gentoo.org/~blueness/install-xattr/"
 
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
@@ -23,6 +23,7 @@ SLOT="0"
 src_prepare() {
        default
        tc-export CC
+       append-cppflags "-D_FILE_OFFSET_BITS=64"
 }
 
 src_compile() {