app-arch/engrampa: Bump to 1.24.0
authorAdam Feldman <NP-Hardass@gentoo.org>
Tue, 24 Mar 2020 04:34:47 +0000 (00:34 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:48:36 +0000 (13:48 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
app-arch/engrampa/Manifest
app-arch/engrampa/engrampa-1.24.0.ebuild [new file with mode: 0644]

index 2774e667ef2c0035e693e66ee6681ba550ff125d..2d82dcf79f7f549312e5663a01039c580bb80dc1 100644 (file)
@@ -1,2 +1,3 @@
 DIST engrampa-1.22.1.tar.xz 1363488 BLAKE2B 0f71e94af50443f9f562b0eed461ca1160fab0a5a3cd02c845fac09ee2466cb8634a458a6a4488ff5ac6674b0f525eccf754b8b1cc7e3f1729d4eb6ac224e025 SHA512 111eeb470555ae8edb7754159bb2e70b03cbbc7b1c9d61c253d9d67e50d84ff0e0654e16547883c39aeeb223e8ba58201d45b50819784fc6cf7a21f0cf176c70
 DIST engrampa-1.22.3.tar.xz 1407412 BLAKE2B d6963da4c18137600c26cff01b2a42d2aaf9a8a435779593b7712e6f7ff920fd25b5fa462edd3d321d63f131b3e4a4486a6f795f2392f6679ae3ef9b343fe8e1 SHA512 fd110b2bc188207645985a6f788b8e618cb4910a275950dfb17c0bcc42eff8765a4c7a36760dec2636485685a7a2f4adefb8e2c83537d1b3a819582e3878c9db
+DIST engrampa-1.24.0.tar.xz 1678920 BLAKE2B c40ba6a77d667f25853f6ae8cef51a54b32402e9446d6712bcfe8b6cfbddcc39e076604fad6ead1717bcedc52716be028ac9bf912c5762fa204e3ee5d6be10bb SHA512 b6996e224ef52d8fd7102e4498193faa62056e8c22aa260ab5c6361533744f78755d500536ec0e03fd8b42b71da56d3f58d9d760809d20b572bee02fdee07cce
diff --git a/app-arch/engrampa/engrampa-1.24.0.ebuild b/app-arch/engrampa/engrampa-1.24.0.ebuild
new file mode 100644 (file)
index 0000000..9810e43
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate readme.gentoo-r1
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Engrampa archive manager for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="caja magic packagekit"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.50:2
+       >=dev-libs/json-glib-0.14
+       virtual/libintl
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/gtk+-3.22:3[X]
+       x11-libs/pango
+       caja? ( >=mate-base/caja-1.17.1 )
+       magic? ( sys-apps/file )
+       packagekit? ( app-admin/packagekit-base )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       virtual/libintl
+       !!app-arch/mate-file-archiver
+"
+
+DEPEND="${COMMON_DEPEND}
+       app-text/yelp-tools
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8:*
+       virtual/pkgconfig
+"
+
+src_configure() {
+       mate_src_configure \
+               --disable-run-in-place \
+               $(use_enable caja caja-actions) \
+               $(use_enable magic) \
+               $(use_enable packagekit)
+}
+
+src_install() {
+       mate_src_install
+}
+
+pkg_postinst() {
+       mate_pkg_postinst
+       optfeature "Support for 7-zip"  app-arch/p7zip
+       optfeature "Support for ace"  app-arch/unace
+       optfeature "Support for arj"  app-arch/arj
+       optfeature "Support for cpio"  app-arch/cpio
+       optfeature "Support for deb"  app-arch/dpkg
+       optfeature "Support for iso"  app-cdr/cdrtools
+       optfeature "Support for jar,zip"  app-arch/zip app-arch/unzip
+       optfeature "Support for lha"  app-arch/lha
+       optfeature "Support for lzma"  app-arch/xz-utils
+       optfeature "Support for lzop"  app-arch/lzop
+       optfeature "Support for rar"  app-arch/unrar
+       optfeature "Support for rpm"  app-arch/rpm
+       optfeature "Support for unstuff"  app-arch/stuffit
+       optfeature "Support for zoo"  app-arch/zoo
+}