dev-vcs/tortoisehg: Removed not python3-compatible
authorDenis Reva <denis7774@gmail.com>
Thu, 16 Apr 2020 14:43:09 +0000 (19:43 +0500)
committerMichał Górny <mgorny@gentoo.org>
Mon, 20 Apr 2020 17:34:23 +0000 (19:34 +0200)
Removed all versions not supported python3

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Denis Reva <denis7774@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-vcs/tortoisehg/Manifest
dev-vcs/tortoisehg/tortoisehg-4.9.1.ebuild [deleted file]
dev-vcs/tortoisehg/tortoisehg-4.9.ebuild [deleted file]
dev-vcs/tortoisehg/tortoisehg-5.0.2.ebuild [deleted file]
dev-vcs/tortoisehg/tortoisehg-9999.ebuild

index fbf83588b2f46e5754ea0554c95a1d872687fb37..7302e05825fb7e26f94c66d14a0f2fde24ec8afd 100644 (file)
@@ -1,4 +1 @@
-DIST tortoisehg-4.9.1.tar.gz 7960667 BLAKE2B f8a6ed65967c6389b65fd9388b3e898bf4ce09e7f95dd88467a10c061b9454eab76d0308905fd417575bf6d75dd7129a2f303bc774fd8e68824b33c18fd8054c SHA512 aef1b0d6047114794bfe78de2c0def83748e238917ce44fb56d562d53c26666dbb385867da70c4625893b148e2affa3766e40292348b78aff428df5a77d8f902
-DIST tortoisehg-4.9.tar.gz 7960163 BLAKE2B bc13032ba1e36ed3e6aca978cb3917b2e5fdcf1b7dab2e66a34a0aca2e084960954f9ec135a1c2120e09931b876db7d1f3d0f3a8f69f950ff939eea9d7814523 SHA512 cc7b0360c6b362b0b9695a484b59eea879e1d4e28ed68e98ce6975342a22ddafc97976c5b0cdea289bfd78932dacf76c0b236e36bec48acd48ee361f2c09ff13
-DIST tortoisehg-5.0.2.tar.gz 8002109 BLAKE2B 3ac66a0b0f943bccc1e9d38f6fb1a788de0e5b538fdf42d59da26de641913802116a73039a2c3516245c1b6abe325b0dd9ca5b2f1c2b60e2dcc6a600e5f1fb97 SHA512 d33916cf3215360cada06de62db46e70c555b1f4cd509f0b863e2baa633e2c5df99f09f3a103444c30aa0a6e15e2acd7134f045cb3846cccc7b727482d94e650
 DIST tortoisehg-5.3.2.tar.gz 8910859 BLAKE2B 4cc2253f0adbd79fe84507043491198ddd9fa559c3e9296c831b8e0fccd6cb2806a31ffd6d417591f5fcb3afce78e696f7052d70b760a566bf72c6602ca31ea8 SHA512 b15894158a0d5e628015d07b4f8c77c96f3e1d7543fe2984693b99b2acfa411922b06683e62de437cb50dd5817155d4e59045d7fb47c9be8ee27b9bccf77da7e
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.9.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.9.1.ebuild
deleted file mode 100644 (file)
index ff68d5c..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit desktop distutils-r1
-
-if [[ ${PV} != *9999* ]]; then
-       KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
-       HG_DEPEND=">=dev-vcs/mercurial-4.8 <dev-vcs/mercurial-4.10"
-else
-       inherit mercurial
-       EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
-       EHG_REVISION="stable"
-       HG_DEPEND="dev-vcs/mercurial"
-fi
-
-DESCRIPTION="Set of graphical tools for Mercurial"
-HOMEPAGE="https://tortoisehg.bitbucket.io/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="${HG_DEPEND}
-       dev-python/iniparse[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-       dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
-       >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( >=dev-python/sphinx-1.0.3 )"
-
-# Workaround race condition in build_qt
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       if [[ ${L10N+set} ]]; then
-               cd i18n/tortoisehg || die
-               local x y keep
-               for x in *.po; do
-                       keep=false
-                       for y in ${L10N}; do
-                               if [[ ${y} == ${x%.po}* ]]; then
-                                       keep=true
-                                       break
-                               fi
-                       done
-                       ${keep} || rm "${x}" || die
-               done
-               cd "${S}" || die
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
-       if use doc ; then
-               docinto html
-               dodoc -r doc/build/html/.
-       fi
-       newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
-       domenu contrib/thg.desktop
-
-       # Remove file that collides with >=mercurial-4.0 (bug #599266).
-       rm "${ED}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py* \
-               || die
-}
-
-pkg_postinst() {
-       elog "When startup of ${PN} fails with an API version mismatch error"
-       elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
-       elog "dev-python/qscintilla-python."
-}
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.9.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.9.ebuild
deleted file mode 100644 (file)
index 6407cbc..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit desktop distutils-r1
-
-if [[ ${PV} != *9999* ]]; then
-       KEYWORDS="amd64 x86"
-       SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
-       HG_DEPEND=">=dev-vcs/mercurial-4.8 <dev-vcs/mercurial-4.10"
-else
-       inherit mercurial
-       EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
-       EHG_REVISION="stable"
-       HG_DEPEND="dev-vcs/mercurial"
-fi
-
-DESCRIPTION="Set of graphical tools for Mercurial"
-HOMEPAGE="https://tortoisehg.bitbucket.io/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="${HG_DEPEND}
-       dev-python/iniparse[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-       dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
-       >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( >=dev-python/sphinx-1.0.3 )"
-
-# Workaround race condition in build_qt
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       if [[ ${L10N+set} ]]; then
-               cd i18n/tortoisehg || die
-               local x y keep
-               for x in *.po; do
-                       keep=false
-                       for y in ${L10N}; do
-                               if [[ ${y} == ${x%.po}* ]]; then
-                                       keep=true
-                                       break
-                               fi
-                       done
-                       ${keep} || rm "${x}" || die
-               done
-               cd "${S}" || die
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
-       if use doc ; then
-               docinto html
-               dodoc -r doc/build/html/.
-       fi
-       newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
-       domenu contrib/thg.desktop
-
-       # Remove file that collides with >=mercurial-4.0 (bug #599266).
-       rm "${ED}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py* \
-               || die
-}
-
-pkg_postinst() {
-       elog "When startup of ${PN} fails with an API version mismatch error"
-       elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
-       elog "dev-python/qscintilla-python."
-}
diff --git a/dev-vcs/tortoisehg/tortoisehg-5.0.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-5.0.2.ebuild
deleted file mode 100644 (file)
index 869a557..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit desktop distutils-r1
-
-if [[ ${PV} != *9999* ]]; then
-       KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
-       HG_DEPEND=">=dev-vcs/mercurial-5.0 <dev-vcs/mercurial-5.1"
-else
-       inherit mercurial
-       EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
-       EHG_REVISION="stable"
-       HG_DEPEND="dev-vcs/mercurial"
-fi
-
-DESCRIPTION="Set of graphical tools for Mercurial"
-HOMEPAGE="https://tortoisehg.bitbucket.io/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="${HG_DEPEND}
-       dev-python/iniparse[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-       dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
-       >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( >=dev-python/sphinx-1.0.3 )"
-
-# Workaround race condition in build_qt
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       if [[ ${L10N+set} ]]; then
-               cd i18n/tortoisehg || die
-               local x y keep
-               for x in *.po; do
-                       keep=false
-                       for y in ${L10N}; do
-                               if [[ ${y} == ${x%.po}* ]]; then
-                                       keep=true
-                                       break
-                               fi
-                       done
-                       ${keep} || rm "${x}" || die
-               done
-               cd "${S}" || die
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
-       if use doc ; then
-               docinto html
-               dodoc -r doc/build/html/.
-       fi
-       newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
-       domenu contrib/thg.desktop
-
-       # Remove file that collides with >=mercurial-4.0 (bug #599266).
-       rm "${ED}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py* \
-               || die
-}
-
-pkg_postinst() {
-       elog "When startup of ${PN} fails with an API version mismatch error"
-       elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
-       elog "dev-python/qscintilla-python."
-}
index 18e015fc174f79ab4fa0dbc56b899c3be2aa4411..6f0201707268c19c930195ee07d41e7e16f05860 100644 (file)
@@ -1,15 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit distutils-r1 eutils
+inherit desktop distutils-r1
 
 if [[ ${PV} != *9999* ]]; then
-       KEYWORDS="~amd64 ~x86"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
        SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
-       HG_DEPEND=">=dev-vcs/mercurial-4.4 <dev-vcs/mercurial-4.6"
+       HG_DEPEND=" >=dev-vcs/mercurial-5.3.1
+               <dev-vcs/mercurial-5.4"
 else
        inherit mercurial
        EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
@@ -24,53 +25,26 @@ LICENSE="GPL-2"
 SLOT="0"
 IUSE="doc"
 
+distutils_enable_sphinx html
+
 RDEPEND="${HG_DEPEND}
        dev-python/iniparse[${PYTHON_USEDEP}]
        dev-python/pygments[${PYTHON_USEDEP}]
        dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
        >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( >=dev-python/sphinx-1.0.3 )"
-
-# Workaround race condition in build_qt
-DISTUTILS_IN_SOURCE_BUILD=1
+DEPEND="${RDEPEND}"
 
 python_prepare_all() {
-       if [[ ${L10N+set} ]]; then
-               cd i18n/tortoisehg || die
-               local x y keep
-               for x in *.po; do
-                       keep=false
-                       for y in ${L10N}; do
-                               if [[ ${y} == ${x%.po}* ]]; then
-                                       keep=true
-                                       break
-                               fi
-                       done
-                       ${keep} || rm "${x}" || die
-               done
-               cd "${S}" || die
-       fi
+       # Remove file that collides with >=mercurial-4.0 (bug #599266).
+       rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
        distutils-r1_python_prepare_all
 }
 
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
 python_install_all() {
        distutils-r1_python_install_all
        dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
-       if use doc ; then
-               docinto html
-               dodoc -r doc/build/html/.
-       fi
        newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
        domenu contrib/thg.desktop
-
-       # Remove file that collides with >=mercurial-4.0 (bug #599266).
-       rm "${ED%/}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
-               || die
 }
 
 pkg_postinst() {