dev-python/portend: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:11:43 +0000 (09:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:11:43 +0000 (09:11 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/portend/portend-2.6.ebuild

index 4d79fd9e5ec4553f8a24ee4c84faeec5e01e96aa..3fc08e4c32cde1ea7caa16e307127a4f8eaf5e56 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1
 
@@ -17,7 +17,6 @@ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
 IUSE="test"
 
 RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
 distutils_enable_tests pytest