dev-python/pyprof2calltree: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 18:07:32 +0000 (19:07 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 18:07:42 +0000 (19:07 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyprof2calltree/Manifest
dev-python/pyprof2calltree/files/pyprof2calltree-1.4.0-py3-test.patch [deleted file]
dev-python/pyprof2calltree/pyprof2calltree-1.4.0.ebuild [deleted file]

index 260a36b16fe42bcf435052e79035e4b2c8e662f7..a7476c489766a47a70c99c8541847b5eb28962f3 100644 (file)
@@ -1,2 +1 @@
-DIST pyprof2calltree-1.4.0.tar.gz 7784 BLAKE2B e8b9ecd857930406bb3b7f7851913a68f1e3433f3b42c262922b5d5b0fbfa692078fdad811d4ca358f7c74d14320c914cfa779ed0b9da8c4fcd7d8e021fd3319 SHA512 b1acba29cd4e5112012eeeffdac53900688a28707306ef3a8a3827f7422c35bc921d59d33db3209db923bb8640014e7d9d7d819eafbcb19e0cf7e6159537bded
 DIST pyprof2calltree-1.4.4.tar.gz 8797 BLAKE2B 0929728d3a6de1cc40e54bd4581bb4b64875a4d7f3ccef725300d40d2b3fd175d8ff462591357e32a471e5c3a4c5c51ac7e9c81c2e857050745a748bc4117d8a SHA512 7ffc228e542a568cb421394035660623415495472b5b3659a35b02c7ccccb7f578dc872d2bb1daf4fdfcd44134e1ad9b5ce3a18f49b15dd4aeb3b5f1201a28d8
diff --git a/dev-python/pyprof2calltree/files/pyprof2calltree-1.4.0-py3-test.patch b/dev-python/pyprof2calltree/files/pyprof2calltree-1.4.0-py3-test.patch
deleted file mode 100644 (file)
index a91818f..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 582eeeaa930639ccfe9b789b057f170824edd73a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 17 May 2017 20:53:29 +0200
-Subject: [PATCH] tests: Fix StringIO import for Python 3
-
-Python 3 no longer provides a 'cStringIO' module. Use StringIO from 'io'
-module instead.
----
- tests/test_integration.py | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_integration.py b/tests/test_integration.py
-index e6f432c..cf02a4f 100644
---- a/tests/test_integration.py
-+++ b/tests/test_integration.py
-@@ -3,7 +3,10 @@ import pstats
- import unittest
- from .profile_code import top, expected_output
--from cStringIO import StringIO
-+try:
-+    from cStringIO import StringIO
-+except ImportError:
-+    from io import StringIO
- from pyprof2calltree import CalltreeConverter
- class MockTimeProfile(cProfile.Profile):
--- 
-2.13.0
-
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.0.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.0.ebuild
deleted file mode 100644 (file)
index f341bae..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="convert python profile data to kcachegrind calltree form"
-HOMEPAGE="https://pypi.org/project/pyprof2calltree/"
-# pypi tarball lacks tests
-SRC_URI="https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
-       "${FILESDIR}"/pyprof2calltree-1.4.0-py3-test.patch
-)
-
-python_test() {
-       "${PYTHON}" -m tests.test_integration || die "Tests fail with ${EPYTHON}"
-}