dev-ros/hector_pose_estimation_core: Bump to 0.3.0.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Jun 2016 13:54:29 +0000 (15:54 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Jun 2016 13:56:18 +0000 (15:56 +0200)
Package-Manager: portage-2.3.0

dev-ros/hector_pose_estimation_core/Manifest
dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0.ebuild [new file with mode: 0644]

index 219ed362f3a097386d50141b3f6d366e16c28490..8d9441c7eb87e12e8d5662983ca0a77bfb859e67 100644 (file)
@@ -1,2 +1,3 @@
 DIST hector_localization-0.2.0.tar.gz 70999 SHA256 e0b01a8d1d285086e4bb738346f5d37ce188f12197bb10e75d66ac0770fc2f18 SHA512 5eab4f1861bbf1f755595700b9cb7e7f3fd1231ac9fe95f7a6f9f22c6d96045ebcecdf01b81464888b8a263fab585eb7d19682b1cc5aab6fa8809f25e7913739 WHIRLPOOL af642d3458d380c18985aa88e10625b4e7f0ae94a8bfaf9d8d4f1e38fa764785a9c95d551c4b0412c0c91649d8d3768a8cc4774fa761b8fce6ca7d21db374dd7
 DIST hector_localization-0.2.1.tar.gz 71312 SHA256 b059305b86045d7714d209992069ba2a588715d49532d387ad2ae3b132580482 SHA512 f2be534c17c631a4f5039dda7bf0be8f84047861e5d2926adace2b5194607ca9289d90d42a6a24a3cd8a24e7cbbac5634e53cf80a9ce7f9b3a94b4ebebf8e3ef WHIRLPOOL 3f2406048a9cc2ec1cca3816db5e35cf9a9624dab96370c0343e5850ab68d898643700edfe399cb5aae09a17e12e87b65ac669ef0c29f3c796919ddee5911042
+DIST hector_localization-0.3.0.tar.gz 73656 SHA256 36dd8dba4496e50df65505707ade089c1e2dfe1855b78081f68706a104c38326 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df WHIRLPOOL 26ef7ff7b5011b81349448954bec84f70841d543668d43e4b50783e48580eb2632ba8713d3df1a75d5e1f2ada7fd60d8dab551cf4392ea4effc49a4272c4855e
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..209d2fc
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extended Kalman Filter (EKF) that estimates the 6DOF pose of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/rostime
+       dev-ros/rosconsole
+       dev-ros/roscpp
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf
+"
+DEPEND="${RDEPEND}
+       dev-cpp/eigen:3"