www-client/chromium: restore pax-mark of intermediate targets
authorMike Gilbert <floppym@gentoo.org>
Sat, 25 Aug 2018 20:26:37 +0000 (16:26 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 25 Aug 2018 20:26:55 +0000 (16:26 -0400)
Closes: https://bugs.gentoo.org/661282
Package-Manager: Portage-2.3.47, Repoman-2.3.10_p41

www-client/chromium/chromium-68.0.3440.106.ebuild
www-client/chromium/chromium-68.0.3440.75.ebuild
www-client/chromium/chromium-69.0.3497.42.ebuild
www-client/chromium/chromium-70.0.3521.2.ebuild

index 16791d0b40c5798d0bfa284990be4fa5a888be77..50f8274850f92348d40df341f0afc735a5a2739f 100644 (file)
@@ -583,6 +583,18 @@ src_compile() {
 
        #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
 
+       # Build mksnapshot and pax-mark it.
+       local x
+       for x in mksnapshot v8_context_snapshot_generator; do
+               if tc-is-cross-compiler; then
+                       eninja -C out/Release "host/${x}"
+                       pax-mark m "out/Release/host/${x}"
+               else
+                       eninja -C out/Release "${x}"
+                       pax-mark m "out/Release/${x}"
+               fi
+       done
+
        # Even though ninja autodetects number of CPUs, we respect
        # user's options, for debugging with -j 1 or any other reason.
        eninja -C out/Release chrome chromedriver
index 8585294049b08fe925885272cdc5774d194cca0c..3864487463f2a271615f2b4c1fb8ea51bdec46a7 100644 (file)
@@ -583,6 +583,18 @@ src_compile() {
 
        #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
 
+       # Build mksnapshot and pax-mark it.
+       local x
+       for x in mksnapshot v8_context_snapshot_generator; do
+               if tc-is-cross-compiler; then
+                       eninja -C out/Release "host/${x}"
+                       pax-mark m "out/Release/host/${x}"
+               else
+                       eninja -C out/Release "${x}"
+                       pax-mark m "out/Release/${x}"
+               fi
+       done
+
        # Even though ninja autodetects number of CPUs, we respect
        # user's options, for debugging with -j 1 or any other reason.
        eninja -C out/Release chrome chromedriver
index dcee9bd0f1c57f20ea59ca76a49025d5875300f9..c3d05bb2729fec0ae45ef9f9fcf39ca3ec8eabca 100644 (file)
@@ -568,6 +568,18 @@ src_compile() {
 
        #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
 
+       # Build mksnapshot and pax-mark it.
+       local x
+       for x in mksnapshot v8_context_snapshot_generator; do
+               if tc-is-cross-compiler; then
+                       eninja -C out/Release "host/${x}"
+                       pax-mark m "out/Release/host/${x}"
+               else
+                       eninja -C out/Release "${x}"
+                       pax-mark m "out/Release/${x}"
+               fi
+       done
+
        # Even though ninja autodetects number of CPUs, we respect
        # user's options, for debugging with -j 1 or any other reason.
        eninja -C out/Release chrome chromedriver
index 953d96e54e41a6903b6005bd0fa68c92950cd5d7..c70f37c2a62f79dcab2ec2a8b4f6112fcd368f13 100644 (file)
@@ -573,6 +573,18 @@ src_compile() {
 
        #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
 
+       # Build mksnapshot and pax-mark it.
+       local x
+       for x in mksnapshot v8_context_snapshot_generator; do
+               if tc-is-cross-compiler; then
+                       eninja -C out/Release "host/${x}"
+                       pax-mark m "out/Release/host/${x}"
+               else
+                       eninja -C out/Release "${x}"
+                       pax-mark m "out/Release/${x}"
+               fi
+       done
+
        # Even though ninja autodetects number of CPUs, we respect
        # user's options, for debugging with -j 1 or any other reason.
        eninja -C out/Release chrome chromedriver