sci-biology/exonerate: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:46:24 +0000 (16:46 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:49:01 +0000 (16:49 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/exonerate/exonerate-2.2.0-r2.ebuild [moved from sci-biology/exonerate/exonerate-2.2.0-r1.ebuild with 53% similarity]
sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch

similarity index 53%
rename from sci-biology/exonerate/exonerate-2.2.0-r1.ebuild
rename to sci-biology/exonerate/exonerate-2.2.0-r2.ebuild
index 966f7c2f8e01926eac6d4a86f7966146883b9c42..567b906ca21de6febc6d5ab5cfc1c68a96adc56f 100644 (file)
@@ -1,50 +1,48 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=4
+EAPI=6
 
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils toolchain-funcs
+inherit autotools toolchain-funcs
 
 DESCRIPTION="Generic tool for pairwise sequence comparison"
-HOMEPAGE="http://www.ebi.ac.uk/~guy/exonerate/"
-SRC_URI="http://www.ebi.ac.uk/~guy/exonerate/${P}.tar.gz"
+HOMEPAGE="https://www.ebi.ac.uk/about/vertebrate-genomics/software/exonerate"
+SRC_URI="http://ftp.ebi.ac.uk/pub/software/vertebrategenomics/exonerate/${P}.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
-IUSE="utils test threads"
-
+IUSE="test threads utils"
 REQUIRED_USE="test? ( utils )"
 
 DEPEND="dev-libs/glib:2"
 RDEPEND="${DEPEND}"
 
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
 PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
 
 src_prepare() {
-       tc-export CC
+       default
        sed \
                -e 's: -O3 -finline-functions::g' \
                -i configure.in || die
-       autotools-utils_src_prepare
+       mv configure.{in,ac} || die
+
+       eautoreconf
 }
 
 src_configure() {
-       local myeconfargs=(
-               $(use_enable utils utilities)
+       tc-export CC
+
+       econf \
+               --enable-glib2 \
+               --enable-largefile \
+               $(use_enable utils utilities) \
                $(use_enable threads pthreads)
-               --enable-largefile
-               --enable-glib2
-       )
-       autotools-utils_src_configure
 }
 
 src_install() {
-       autotools-utils_src_install
+       default
+
        doman doc/man/man1/*.1
 }
index 3268055cd5442419a95e5c65c5ea3387b063c96b..5c428979a1af149f866a89aa9038be48de4119e7 100644 (file)
@@ -2,8 +2,8 @@ Fix build with --as-needed
 
 https://bugs.gentoo.org/268094
 
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
 @@ -289,7 +289,7 @@
  if test "$enable_pthreads" = yes; then
      echo "Using PTHREADS"