gnome-base/librsvg: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 2 Jul 2016 12:48:35 +0000 (14:48 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 2 Jul 2016 13:30:36 +0000 (15:30 +0200)
Package-Manager: portage-2.3.0_rc1

gnome-base/librsvg/Manifest
gnome-base/librsvg/librsvg-2.40.16.ebuild [new file with mode: 0644]

index 659fa992237f318f4777842d697d824cae76996e..fc0c44f751423acbdb40ba103c51f02274ee02b3 100644 (file)
@@ -1,2 +1,3 @@
 DIST librsvg-2.40.11.tar.xz 539428 SHA256 611ac0f544debd0c9bf1ef5509c990d218e83dd1d8c83297075c4b29796a2e02 SHA512 89fc4f94150ab47665ab1b6c26979c8072efe40dd74ff13284598cb63de8594e7cfe4b73a151e54002a4811b5de56b93f5d52215ef0862b994d230fafe04b4fc WHIRLPOOL 7c9a0292faf42dd396a59b38c6900a1b78a254c8bd8c724b5636d506c41934d19c924fbf86c2faab7151c065dd134252b78adfd94940b09acd601ef2dc86a5cc
 DIST librsvg-2.40.15.tar.xz 554608 SHA256 d9cac4a123eec6e553a26e120979bab7425def9ae7ce7c079eba5e4a45db05f4 SHA512 1169c02247dbf3d71d3d4bfb1aa2580a4b1e243e1c2c6d1c86aaa09c54c66857b959df4358a1ca6a34ec5fbb34b9529963b993fc978ec1fe401dbc56ac460101 WHIRLPOOL 687e9afc6c1c46079fa9005c94ed329ff6f681a9fb784df999efca36ba1fac05a05f3d6413105993ff4af60a62a36b647e2f1335ab1245c621de2ff76ccef479
+DIST librsvg-2.40.16.tar.xz 560800 SHA256 d48bcf6b03fa98f07df10332fb49d8c010786ddca6ab34cbba217684f533ff2e SHA512 975a0f900c5a9598ef91bbf936d99319c6efe493f35525a23c5c7f2ed37c5839ec8e5d29f297219b3049f10e2594ebdf41c987b49c004ef3c846963f055c468a WHIRLPOOL 7e1feac4ce98a95f15ea721782919295a8123c33c828ff686d3ab86f8a4d2ab06b88f17dbd9ad749fd5df0829b717a5fd73a0d21ebe308bf8905e9174e50717c
diff --git a/gnome-base/librsvg/librsvg-2.40.16.ebuild b/gnome-base/librsvg/librsvg-2.40.16.ebuild
new file mode 100644 (file)
index 0000000..0102418
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils gnome2 multilib-minimal vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibRsvg"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="+introspection tools vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+       >=x11-libs/cairo-1.12.14-r4[${MULTILIB_USEDEP}]
+       >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+       >=dev-libs/libcroco-0.6.8-r1[${MULTILIB_USEDEP}]
+       >=x11-libs/gdk-pixbuf-2.30.7:2[introspection?,${MULTILIB_USEDEP}]
+       introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+       tools? ( >=x11-libs/gtk+-3.10.0:3 )
+"
+DEPEND="${RDEPEND}
+       dev-libs/gobject-introspection-common
+       dev-libs/vala-common
+       >=dev-util/gtk-doc-am-1.13
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       vala? ( $(vala_depend) )
+"
+# >=gtk-doc-am-1.13, gobject-introspection-common, vala-common needed by eautoreconf
+
+src_prepare() {
+       # https://bugzilla.gnome.org/show_bug.cgi?id=653323
+       eapply "${FILESDIR}/${PN}-2.40.12-gtk-optional.patch"
+
+       # https://bugzilla.gnome.org/show_bug.cgi?id=731826
+       eapply "${FILESDIR}/${PN}-2.40.2-vala-out-of-source.patch"
+
+       eautoreconf
+
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       local myconf=()
+
+       # -Bsymbolic is not supported by the Darwin toolchain
+       if [[ ${CHOST} == *-darwin* ]]; then
+               myconf+=( --disable-Bsymbolic )
+       fi
+
+       # --disable-tools even when USE=tools; the tools/ subdirectory is useful
+       # only for librsvg developers
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               --disable-static \
+               --disable-tools \
+               $(multilib_native_use_enable introspection) \
+               $(multilib_native_use_with tools gtk3) \
+               $(multilib_native_use_enable vala) \
+               --enable-pixbuf-loader \
+               "${myconf[@]}"
+
+       if multilib_is_native_abi; then
+               ln -s "${S}"/doc/html doc/html || die
+       fi
+}
+
+multilib_src_compile() {
+       # causes segfault if set, see bug #411765
+       unset __GL_NO_DSO_FINALIZER
+       gnome2_src_compile
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}
+
+pkg_postinst() {
+       # causes segfault if set, see bug 375615
+       unset __GL_NO_DSO_FINALIZER
+       multilib_foreach_abi gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+       # causes segfault if set, see bug 375615
+       unset __GL_NO_DSO_FINALIZER
+       multilib_foreach_abi gnome2_pkg_postrm
+}