app-portage/gentoolkit: Bump to version 0.4.6
authorZac Medico <zmedico@gentoo.org>
Mon, 19 Aug 2019 04:00:56 +0000 (21:00 -0700)
committerZac Medico <zmedico@gentoo.org>
Mon, 19 Aug 2019 05:06:14 +0000 (22:06 -0700)
Bug: https://bugs.gentoo.org/463952
Bug: https://bugs.gentoo.org/634824
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-portage/gentoolkit/Manifest
app-portage/gentoolkit/gentoolkit-0.4.6.ebuild [new file with mode: 0644]

index e1cc0292b508e8b6c504cba6249c023221c21c32..8e19d1d610ccc13b03af8dfe71c85886241b383b 100644 (file)
@@ -1,2 +1,3 @@
 DIST gentoolkit-0.4.2.tar.gz 3215652 BLAKE2B 97b4dcac7293b50161169a6c777623cb1c51e2f74020e0fa2f1f4441c203c03a1269c8c55e1461c5780ebfb8234d364837073d582a52a99f2d40c92e6b77a7f0 SHA512 3a9eac2fd214bcfe39380193cb2118edcd759dbf3eb165e7240525ce1047aa984f1d1f1d3a15324218d9be1f0a1ec960ae08a63191392f1bb3422277a52697ff
 DIST gentoolkit-0.4.5.tar.gz 3218757 BLAKE2B 9ac6e7bdee622ff3069ee0f59a1834f36496f2bd07c53a67677571e0cfc99366ba64d03fca8bd964c3517d7cbcb7d4d5d08e9f3ec721d7adf598b13944fea659 SHA512 6b459684a59c5a72f09da34a2e9491b98f49c861f763bddb52ae002413a2c89d7841d84658577e6fec36a096889265a1207eaf981adfdd5e9db6ad79ca364df3
+DIST gentoolkit-0.4.6.tar.gz 3205641 BLAKE2B 7da91a313c8a9263eb7b4abd6207ece9dd602a5069a87f1e78ada13fc9f396e1f2afddaf0637c473445034cf57b5ca7631e209361a88fa3892d302b20f4cc986 SHA512 3aa3c9af7e994313400607943b9090fd813227ddd6d550b50fbcf7eeb4053da8bcdb41c9ef2579d957d2f279fdcc4e2f2ceca1091c5fd457df4204dd11792d6e
diff --git a/app-portage/gentoolkit/gentoolkit-0.4.6.ebuild b/app-portage/gentoolkit/gentoolkit-0.4.6.ebuild
new file mode 100644 (file)
index 0000000..5e01ac6
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_REQ_USE="xml(+),threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoolkit.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="
+       sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+       sys-apps/gawk
+       sys-apps/gentoo-functions"
+
+python_prepare_all() {
+       python_setup
+       echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+       VERSION="${PVR}" "${PYTHON}" setup.py set_version
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+}
+
+pkg_preinst() {
+       if has_version "<${CATEGORY}/${PN}-0.4.0"; then
+               SHOW_GENTOOKIT_DEV_DEPRECATED_MSG=1
+       fi
+}
+
+pkg_postinst() {
+       # Create cache directory for revdep-rebuild
+       mkdir -p -m 0755 "${EROOT%/}"/var/cache
+       mkdir -p -m 0700 "${EROOT%/}"/var/cache/revdep-rebuild
+
+       if [[ ${SHOW_GENTOOKIT_DEV_DEPRECATED_MSG} ]]; then
+               elog "Starting with version 0.4.0, ebump, ekeyword and imlate are now"
+               elog "part of the gentoolkit package."
+               elog "The gentoolkit-dev package is now deprecated in favor of a single"
+               elog "gentoolkit package.   The remaining tools from gentoolkit-dev"
+               elog "are now obsolete/unused with the git based tree."
+       fi
+
+       # Only show the elog information on a new install
+       if [[ ! ${REPLACING_VERSIONS} ]]; then
+               elog
+               elog "For further information on gentoolkit, please read the gentoolkit"
+               elog "guide: https://wiki.gentoo.org/wiki/Gentoolkit"
+               elog
+               elog "Another alternative to equery is app-portage/portage-utils"
+               elog
+               elog "Additional tools that may be of interest:"
+               elog
+               elog "    app-admin/eclean-kernel"
+               elog "    app-portage/diffmask"
+               elog "    app-portage/flaggie"
+               elog "    app-portage/install-mask"
+               elog "    app-portage/portpeek"
+               elog "    app-portage/smart-live-rebuild"
+       fi
+}