dev-python/jaraco-functools: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:54:58 +0000 (13:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:59:53 +0000 (13:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jaraco-functools/Manifest
dev-python/jaraco-functools/jaraco-functools-1.19-r1.ebuild [deleted file]

index 21e02291b87b7e303a5cc9bc940da6d01aef0eab..68c4a31fd88b59fc23d6826c7ac31b7e0fb0adae 100644 (file)
@@ -1,3 +1,2 @@
-DIST jaraco.functools-1.19.tar.gz 10588 BLAKE2B c71eb4e0c611f6a0bd82e04cacb7933961ba5e50091439c274bd8ceeda68b69789423994fe43f44af6cdd643b7a04418bc32ce2f937d118520298a019c5c6638 SHA512 7fbf1956ff8a132021e1f7fae5e98f40199a5d0e705b08b44ad5b2588fdd7d1088db9d7457b985c1852b50285a8f03cc9795fff0c4f53f9155f7c8ec371ff307
 DIST jaraco.functools-2.0.tar.gz 14340 BLAKE2B 560490b1150c2385f9c4d468fe7ab4fa84475ad43e1ebed784343a71742976ed0c18df3f6240b1d5b69106a6835c0248838331a654f9d3fdc863622c3dda33be SHA512 dce30c08f0e9f3c7b682c78fc3a46a26d9972706f4c8449a12ba11aa5ed130c6d9ca405213fd93b6b4110ef9cea549e5fa925c96bfaf18681cd6957d8ba0889f
 DIST jaraco.functools-3.0.0.tar.gz 15618 BLAKE2B dbf542148d18069e7e78c718f3f6b62c7a07c674c96d54dfb3c1cebded13f6e24ca579844453352d001d312e718acf58d311c198076e85217362ee1a1446dc23 SHA512 f1ec725e132477f7361f7d0a77f72b69603499c24df25c9e8e0cc9a6d34a4bd4bb10fde60dc324b8176c46035e2babde04de90fcb0aa82273bc2f8559b8b31f5
diff --git a/dev-python/jaraco-functools/jaraco-functools-1.19-r1.ebuild b/dev-python/jaraco-functools/jaraco-functools-1.19-r1.ebuild
deleted file mode 100644 (file)
index 99f489e..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Additional functions used by other projects by developer jaraco"
-HOMEPAGE="https://github.com/jaraco/jaraco.functools"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       <dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
-       dev-python/more-itertools[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-       doc? (
-               >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
-               >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-       )
-       test? (
-               ${RDEPEND}
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-               dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
-               dev-python/jaraco-classes[${PYTHON_USEDEP}]
-               dev-python/six[${PYTHON_USEDEP}]
-       )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
-       if use doc; then
-               cd docs || die
-               sphinx-build . _build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       # Override pytest options to skip flake8
-       PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
-               || die "tests failed with ${EPYTHON}"
-       }
-
-python_install_all() {
-       distutils-r1_python_install_all
-       find "${ED}" -name '*.pth' -delete || die
-}