dev-libs/apr-util: Bump to version 1.6.1
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 23 Oct 2017 08:54:07 +0000 (10:54 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 23 Oct 2017 08:54:58 +0000 (10:54 +0200)
Package-Manager: Portage-2.3.12, Repoman-2.3.3

dev-libs/apr-util/Manifest
dev-libs/apr-util/apr-util-1.6.1.ebuild [new file with mode: 0644]

index e9d90f82b1fab4c762bfdfc51725fdc42ca111cf..f91748731a6f692227c7b66b799638b89b78b629 100644 (file)
@@ -1,2 +1,3 @@
 DIST apr-util-1.5.4.tar.bz2 694427 SHA256 a6cf327189ca0df2fb9d5633d7326c460fe2b61684745fd7963e79a6dd0dc82e SHA512 ca877d8e444218c4ba0f28063ee075ddcd6c0a487b692dc80ef442fe775ec4eeb337c6957853772e8082e27edcb450d7e909c2c6c3ab4a95bbf0a5ee5ea4a2d1 WHIRLPOOL bc4ce82785513f4bf2207bb26758abc79e6bfef62a57d3e2ead570abc618b321c302390b9dcd8eab1ec44a9e5d398c2cc4d35af2549636e20d7c20678725ac2e
 DIST apr-util-1.6.0.tar.bz2 428750 SHA256 8474c93fa74b56ac6ca87449abe3e155723d5f534727f3f33283f6631a48ca4c SHA512 dc88c13ef6116ed1c67584436cb8ca94ef77d358cb60c7cafab953d36d00564776414faed43397755e79bcf1b14dfca81cad2e280a2dd4c31f6e4559583effd0 WHIRLPOOL a41e90c781d6fd0792ba4d4941744d61bee2289b72529ccca92fbcb671234e80d7faee7e6fa8cf86e6f2d822e6429cff17721a96fdb6527f0802cbd6ed4c1284
+DIST apr-util-1.6.1.tar.bz2 428595 SHA256 d3e12f7b6ad12687572a3a39475545a072608f4ba03a6ce8a3778f607dd0035b SHA512 40eff8a37c0634f7fdddd6ca5e596b38de15fd10767a34c30bbe49c632816e8f3e1e230678034f578dd5816a94f246fb5dfdf48d644829af13bf28de3225205d WHIRLPOOL 66ec9e7f5c596c0eba93329d61b565013bd16388e958bf50f947d977e11ef0a562cf72aa6cce3f24d0748f0f296a011ecbf2a61b6ee5333e0baf3e91ea429fa7
diff --git a/dev-libs/apr-util/apr-util-1.6.1.ebuild b/dev-libs/apr-util/apr-util-1.6.1.ebuild
new file mode 100644 (file)
index 0000000..ec528c1
--- /dev/null
@@ -0,0 +1,135 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
+# APR_PV="${PV}"
+APR_PV="1.6.2"
+
+inherit autotools db-use eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="berkdb doc gdbm ldap libressl mysql nss odbc openssl postgres sqlite static-libs"
+#RESTRICT="test"
+
+RDEPEND="
+       dev-libs/expat
+       >=dev-libs/apr-${APR_PV}:1
+       berkdb? ( >=sys-libs/db-4:= )
+       gdbm? ( sys-libs/gdbm )
+       ldap? ( =net-nds/openldap-2* )
+       mysql? ( =virtual/mysql-5* )
+       nss? ( dev-libs/nss )
+       odbc? ( dev-db/unixODBC )
+       openssl? (
+               !libressl? ( dev-libs/openssl:0 )
+               libressl? ( dev-libs/libressl )
+       )
+       postgres? ( dev-db/postgresql:= )
+       sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="
+       ${RDEPEND}
+       >=sys-devel/libtool-2.4.2
+       doc? ( app-doc/doxygen )
+"
+
+DOCS=(CHANGES NOTICE README)
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.5.3-sysroot.patch #385775
+)
+
+src_prepare() {
+       default
+
+       # Fix usage of libmysqlclient (bug #620230)
+       grep -lrF "libmysqlclient_r" "${S}" \
+               | xargs sed 's@libmysqlclient_r@libmysqlclient@g' -i \
+               || die
+
+       mv configure.{in,ac} || die
+       eautoreconf
+       elibtoolize
+}
+
+src_configure() {
+       local myconf=(
+               --datadir="${EPREFIX}"/usr/share/apr-util-1
+               --with-apr="${SYSROOT}${EPREFIX}"/usr
+               --with-expat="${EPREFIX}"/usr
+               --without-sqlite2
+               $(use_with gdbm)
+               $(use_with ldap)
+               $(use_with mysql)
+               $(use_with nss)
+               $(use_with odbc)
+               $(use_with openssl)
+               $(use_with postgres pgsql)
+               $(use_with sqlite sqlite3)
+       )
+
+       tc-is-static-only && myconf+=( --disable-util-dso )
+
+       if use berkdb; then
+               local db_version
+               db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
+               db_version="$(db_ver_to_slot "${db_version}")"
+               db_version="${db_version/\./}"
+               myconf+=(
+                       --with-dbm=db${db_version}
+                       # We use $T for the libdir because otherwise it'd simply be the normal
+                       # system libdir.  That's pointless as the compiler will search it for
+                       # us already.  This makes cross-compiling and such easier.
+                       --with-berkeley-db="${SYSROOT}$(db_includedir 2>/dev/null):${T}"
+               )
+       else
+               myconf+=( --without-berkeley-db )
+       fi
+
+       if use nss || use openssl ; then
+               myconf+=( --with-crypto ) # 518708
+       fi
+
+       econf "${myconf[@]}"
+       # Use the current env build settings rather than whatever apr was built with.
+       sed -i -r \
+               -e "/^(apr_builddir|apr_builders|top_builddir)=/s:=:=${SYSROOT}:" \
+               -e "/^CC=/s:=.*:=$(tc-getCC):" \
+               -e '/^(C|CPP|CXX|LD)FLAGS=/d' \
+               -e '/^LTFLAGS/s:--silent::' \
+               build/rules.mk || die
+}
+
+src_compile() {
+       emake
+       use doc && emake dox
+}
+
+src_install() {
+       default
+
+       find "${ED}" -name "*.la" -delete || die
+       if [[ -d "${ED%/}/usr/$(get_libdir)/apr-util-${SLOT}" ]] ; then
+               find "${ED%/}/usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -delete || die
+       fi
+       if ! use static-libs ; then
+               find "${ED}" -name "*.a" -not -name "*$(get_libname)" -delete || die
+       fi
+
+       if use doc ; then
+               docinto html
+               dodoc -r docs/dox/html/*
+       fi
+
+       # This file is only used on AIX systems, which Gentoo is not,
+       # and causes collisions between the SLOTs, so remove it.
+       rm "${ED%/}/usr/$(get_libdir)/aprutil.exp" || die
+}