www-apps/nikola: add missing die.
authorPatrice Clement <monsieurp@gentoo.org>
Tue, 11 Jul 2017 07:45:16 +0000 (09:45 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 11 Jul 2017 07:56:19 +0000 (09:56 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

www-apps/nikola/nikola-7.8.8.ebuild

index 43a622c0fae680496360f8964ce292165915c903..b5dd7d5192621d7ed53f4dd1177611a2992d2be8 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=6
 PYTHON_COMPAT=( python{2_7,3_4} )  # 3.5 and 3.6 wait for dependencies
+
 inherit distutils-r1
 
 MY_PN="Nikola"
@@ -47,14 +48,14 @@ RDEPEND="${DEPEND}
        websocket? ( ~dev-python/ws4py-0.3.4[${PYTHON_USEDEP}] )"
 #      typography? ( >=dev-python/typogrify-2.0.4[${PYTHON_USEDEP}] ) # needs smartypants
 
-S="${WORKDIR}"/${MY_P}
+S="${WORKDIR}/${MY_P}"
 
 src_install() {
        distutils-r1_src_install
 
        # hackish way to remove docs that ended up in the wrong place
-       rm -rf "${D}"/usr/share/doc/${PN}
+       rm -rv "${D}/usr/share/doc/${PN}" || die
 
        dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
-       doman docs/man/${PN}.1.gz
+       doman "docs/man/${PN}.1.gz"
 }