app-arch/libarchive: Add explicit flag for blake2 (libb2)
authorMichał Górny <mgorny@gentoo.org>
Sun, 27 Oct 2019 13:28:26 +0000 (14:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 27 Oct 2019 17:11:16 +0000 (18:11 +0100)
Closes: https://bugs.gentoo.org/698254
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/13466
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-arch/libarchive/libarchive-3.4.0.ebuild
app-arch/libarchive/metadata.xml

index ded576e7b675e5acc8a290cb4c9945c678bc194c..136aaa944c927a780d690552ad3b85ae6006aba8 100644 (file)
@@ -11,10 +11,11 @@ SRC_URI="https://www.libarchive.org/downloads/${P}.tar.gz"
 LICENSE="BSD BSD-2 BSD-4 public-domain"
 SLOT="0/13"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="acl +bzip2 +e2fsprogs expat +iconv kernel_linux libressl lz4 +lzma lzo nettle static-libs +threads xattr +zlib zstd"
+IUSE="acl blake2 +bzip2 +e2fsprogs expat +iconv kernel_linux libressl lz4 +lzma lzo nettle static-libs +threads xattr +zlib zstd"
 
 RDEPEND="
        acl? ( virtual/acl[${MULTILIB_USEDEP}] )
+       blake2? ( app-crypt/libb2[${MULTILIB_USEDEP}] )
        bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
        expat? ( dev-libs/expat[${MULTILIB_USEDEP}] )
        !expat? ( dev-libs/libxml2[${MULTILIB_USEDEP}] )
@@ -57,6 +58,7 @@ multilib_src_configure() {
                $(use_enable acl)
                $(use_enable static-libs static)
                $(use_enable xattr)
+               $(use_with blake2 libb2)
                $(use_with bzip2 bz2lib)
                $(use_with expat)
                $(use_with !expat xml2)
index 1da101e8d49fdbfc488c7f2f73ecf64028b808c2..82253c34ca0f6d00be9b50c426f3d1b40254f23b 100644 (file)
@@ -9,6 +9,9 @@
                C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats.
        </longdescription>
        <use>
+               <flag name="blake2">
+                       Enable Blake2 hash support via <pkg>app-crypt/libb2</pkg>.
+               </flag>
                <flag name="bzip2">
                        Allow accessing bzip2-compressed archives through libbz2 (which
                        comes with <pkg>app-arch/bzip2</pkg>). This only affects