dev-python/python-dateutil: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 20:50:21 +0000 (21:50 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:10:56 +0000 (22:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-dateutil/Manifest
dev-python/python-dateutil/python-dateutil-2.7.2-r1.ebuild [deleted file]
dev-python/python-dateutil/python-dateutil-2.8.0.ebuild [deleted file]

index 7ca06e4ef786d5f1abc26cd66b29763d2c9beb76..9eb681136f6b8b564cd8d89568b266e87506fae5 100644 (file)
@@ -1,3 +1 @@
-DIST python-dateutil-2.7.2.tar.gz 298000 BLAKE2B 4091108b125eb080809c74cdb53daa27973b2dc4b2c4f79eba2afb295fce7b6c21a8589d4643ad5af212900f55dc4139711929d5c7c4a2b094ac749d76125761 SHA512 b8fdc867aa67c4e5602bb3e9bf906dd4d32a6616fcdfd5f39d146d849a46d13c266bc9c2eae28490399fe608ba19dcb824d05ce96d556de07999449eaece7dfc
-DIST python-dateutil-2.8.0.tar.gz 327134 BLAKE2B 6525eee57aeaef3c588413210df7c1ad3627a380c6e44af78e9acc9abea523b29e8d9afec495f8d1e585d25d32ab82e6e28bf93dca148893d2e6a533e1f4ce47 SHA512 ec7da86203572582f883a4686acf8a732a2de4f396d809057eb51b2c60dbca5623a7fa90c2c0618c281a2282c60841739bd837731a51cc876f4ff369297f2f81
 DIST python-dateutil-2.8.1.tar.gz 331745 BLAKE2B 9785fe93976d9bbe21d6610133e37e558cdde4062a1a738ccbf2bf80aa062882ba59c60f2b9bfc44c53e0f8fc4b5ebdd5d12b6ba54a60706576360e453b2f160 SHA512 337000216e0f8ce32d6363768444144183ab9268f69082f20858f2b3322b1c449e53b2f2b5dcb3645be22294659ce7838f74ace2fd7a7c4f2adc6cf806a9fa2c
diff --git a/dev-python/python-dateutil/python-dateutil-2.7.2-r1.ebuild b/dev-python/python-dateutil/python-dateutil-2.7.2-r1.ebuild
deleted file mode 100644 (file)
index 8668b53..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the standard Python datetime module"
-HOMEPAGE="
-       https://dateutil.readthedocs.org/
-       https://pypi.org/project/python-dateutil
-       https://github.com/dateutil/dateutil/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/six-1.5[${PYTHON_USEDEP}]
-       sys-libs/timezone-data
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/freezegun[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       local PATCHES=(
-               "${FILESDIR}"/0001-zoneinfo-Get-timezone-data-from-system-tzdata.patch
-       )
-
-       # don't install zoneinfo tarball
-       sed -i '/package_data=/d' setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test -v || die "Tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild b/dev-python/python-dateutil/python-dateutil-2.8.0.ebuild
deleted file mode 100644 (file)
index c82f703..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the standard Python datetime module"
-HOMEPAGE="
-       https://dateutil.readthedocs.org/
-       https://pypi.org/project/python-dateutil
-       https://github.com/dateutil/dateutil/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/six-1.5[${PYTHON_USEDEP}]
-       sys-libs/timezone-data
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/freezegun[${PYTHON_USEDEP}]
-               dev-python/hypothesis[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       local PATCHES=(
-               "${FILESDIR}"/0001-zoneinfo-Get-timezone-data-from-system-tzdata-r1.patch
-       )
-
-       # don't install zoneinfo tarball
-       sed -i '/package_data=/d' setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test -v || die "Tests failed under ${EPYTHON}"
-}