dev-ros/mk: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 11:42:55 +0000 (13:42 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 11:42:55 +0000 (13:42 +0200)
Package-Manager: portage-2.2.21

dev-ros/mk/Manifest [new file with mode: 0644]
dev-ros/mk/metadata.xml [new file with mode: 0644]
dev-ros/mk/mk-1.12.3.ebuild [new file with mode: 0644]
dev-ros/mk/mk-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/mk/Manifest b/dev-ros/mk/Manifest
new file mode 100644 (file)
index 0000000..02c7ccc
--- /dev/null
@@ -0,0 +1 @@
+DIST ros-1.12.3.tar.gz 162506 SHA256 49b9368e901d69f464b46c9ff0d12843d413fe20c4271225dbb75169bb82a47e SHA512 fe740f357959ed2cabcf0d902c7f1ebe6a7dedd11376ec76e5f47383b0b29b15127306255bea9adb3a48b2872a681a10302f9b0c4da4625c31bcc78522b66d7c WHIRLPOOL d57a877f7b7dc2a6613d3ea07b59e740e25bfffbcec51fa4ce826ccdc9f95dd9aed121736f46338068f9cf06b52a6abc8462ce663bbd4519e7d93f16422995f5
diff --git a/dev-ros/mk/metadata.xml b/dev-ros/mk/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/mk/mk-1.12.3.ebuild b/dev-ros/mk/mk-1.12.3.ebuild
new file mode 100644 (file)
index 0000000..fe1f6e9
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A collection of .mk include files for building ROS architectural elements"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/mk/mk-9999.ebuild b/dev-ros/mk/mk-9999.ebuild
new file mode 100644 (file)
index 0000000..fe1f6e9
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A collection of .mk include files for building ROS architectural elements"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"