app-editors/curses-hexedit: various fixes
authorMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 15:11:44 +0000 (11:11 -0400)
committerMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 15:13:19 +0000 (11:13 -0400)
* Update to EAPI=5
* Use subslots w/ncurses dep
* Set up a sane CC value by default
* Force CONFIG_SHELL as non-bash /bin/sh breaks things

Maybe someday there will be a new release w/configure generated by a
recent autoconf and we can drop some of these hacks.

app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild

index 4ba0ace025b7482f583c5a989910ff9f51daeca5..0d5772286225e951c64cad71afa11874cefd2280 100644 (file)
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 # There's already a "hexedit" package in the tree, so name this one differently
 
-EAPI="4"
+EAPI="5"
+
+inherit toolchain-funcs
 
 MY_P=${P/curses-}
 DESCRIPTION="full screen curses hex editor (with insert/delete support)"
@@ -16,11 +18,14 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE=""
 
-RDEPEND="sys-libs/ncurses"
+RDEPEND="sys-libs/ncurses:="
 DEPEND="${RDEPEND}"
 
 S=${WORKDIR}/${MY_P}
 
 src_configure() {
+       # Package has an old configure script.
+       CONFIG_SHELL="/bin/bash"
+       tc-export CC
        econf --program-prefix=curses-
 }