dev-vcs/mercurial: Security cleanup
authorSam James (sam_c) <sam@cmpct.info>
Sun, 22 Mar 2020 00:32:38 +0000 (00:32 +0000)
committerCédric Krier <cedk@gentoo.org>
Sun, 22 Mar 2020 10:13:46 +0000 (11:13 +0100)
Bug: https://bugs.gentoo.org/680206
Closes: https://github.com/gentoo/gentoo/pull/15048
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Signed-off-by: Cédric Krier <cedk@gentoo.org>
dev-vcs/mercurial/Manifest
dev-vcs/mercurial/mercurial-4.6.2.ebuild [deleted file]

index 39563ed60705c5e72b7d66c29bd5f51c467fd72f..e72bc99dfb3c8f089f23fa6a119cac5e5de61256 100644 (file)
@@ -1,4 +1,3 @@
-DIST mercurial-4.6.2.tar.gz 6407989 BLAKE2B 22aa121b2544e3597f2ea4d3a7a80b3b8f5ca6f9de15326dbee555ca3d14b8a552042c4448aae17b1c015b4f302c3512c204f17a834b758f51fbcc2455ed4e6f SHA512 71afb9ed3f62b1b946563c55851dda1fc8b724afe82a4a253c7f4719ae9e1160d5f9644bed7fd27ee3a21d8e682352364fc9f47bafa552cd4cd7fac7c0d42bdd
 DIST mercurial-4.9.1.tar.gz 7076867 BLAKE2B 8cedc66a8ddffc543a8849bbc98ebfc9ed61055a2ad16506b8c1c9a932d6825ef01a63b31f5bdbdb25e8829badab72857f101d12576fb269572c3d03cb4e7abd SHA512 2265ab501e24a2d229ef29404ca35d318faf620db163ec33225348d53139f7b6cb121e935ce444ec697ced69697f43df57dd7199ad20c1ca6f0275d9744ce391
 DIST mercurial-4.9.tar.gz 7075692 BLAKE2B ed11442e0cd5b27f47394ed1c15016930556d5cdc59ab18f1e0d5371e434eb752b68d3d9f6dd34ed9c63df62a646223e86c6c5178775d9b856eed5df65677900 SHA512 59a5467cebb51f17cce7bcada37f8d85906493ab2e3d443ceeae2c6598fb69d2d59f1e99c73bd08345c5f90501a7bae0d70e04c770ea7653ec30648e591c97fb
 DIST mercurial-5.0.2.tar.gz 7202797 BLAKE2B 7059efa2cf80c433ec25748c7c49ae0caa688363f5ef2983e0adf39a0a691ea99aaf4a090ebeda11b89e74263c548289cca3f82f40d77efbf925e12231b341cc SHA512 8b328e2e5a2896b690492d75c055bb13cd76df6efb087ef770f60ead86e30f7d952cb3ca82a696c0c5ce7039c319bd0fc9b448a52c079653622760317d5bb315
diff --git a/dev-vcs/mercurial/mercurial-4.6.2.ebuild b/dev-vcs/mercurial/mercurial-4.6.2.ebuild
deleted file mode 100644 (file)
index 1c5db61..0000000
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads"
-
-inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="https://www.mercurial-scm.org/"
-SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bugzilla emacs gpg test tk"
-
-RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
-       gpg? ( app-crypt/gnupg )
-       tk? ( dev-lang/tk )
-       app-misc/ca-certificates"
-DEPEND="emacs? ( >=app-editors/emacs-23.1:* )
-       test? ( app-arch/unzip
-               dev-python/pygments[${PYTHON_USEDEP}] )"
-
-SITEFILE="70${PN}-gentoo.el"
-
-# Too many tests fail #608720
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )
-
-python_prepare_all() {
-       # fix up logic that won't work in Gentoo Prefix (also won't outside in
-       # certain cases), bug #362891
-       sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
-       filter-flags -ftracer -ftree-vectorize
-       # Note: make it impl-conditional if py3 is supported
-       append-flags -fno-strict-aliasing
-
-       "${PYTHON}" setup.py build_mo || die
-}
-
-python_compile_all() {
-       rm -r contrib/{win32,macosx} || die
-       if use emacs; then
-               cd contrib || die
-               elisp-compile mercurial.el || die "elisp-compile failed!"
-       fi
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       newbashcomp contrib/bash_completion hg
-
-       insinto /usr/share/zsh/site-functions
-       newins contrib/zsh_completion _hg
-
-       rm -f doc/*.?.txt
-       dodoc CONTRIBUTORS
-       cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
-
-       dobin hgeditor
-       dobin contrib/hgk
-       python_foreach_impl python_doscript contrib/hg-ssh
-
-       if use emacs; then
-               elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
-               elisp-site-file-install "${FILESDIR}"/${SITEFILE}
-       fi
-
-       local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
-                         *.el mercurial.spec)
-       for f in ${RM_CONTRIB[@]}; do
-               rm -r contrib/$f || die
-       done
-
-       dodoc -r contrib
-       docompress -x /usr/share/doc/${PF}/contrib
-       doman doc/*.?
-
-       insinto /etc/mercurial/hgrc.d
-       doins "${FILESDIR}/cacerts.rc"
-}
-
-src_test() {
-       pushd tests &>/dev/null || die
-       rm -rf *svn*                    # Subversion tests fail with 1.5
-       rm -f test-archive*             # Fails due to verbose tar output changes
-       rm -f test-convert-baz*         # GNU Arch baz
-       rm -f test-convert-cvs*         # CVS
-       rm -f test-convert-darcs*       # Darcs
-       rm -f test-convert-git*         # git
-       rm -f test-convert-mtn*         # monotone
-       rm -f test-convert-tla*         # GNU Arch tla
-       #rm -f test-doctest*            # doctest always fails with python 2.5.x
-       rm -f test-largefiles*          # tends to time out
-
-       popd &>/dev/null || die
-       distutils-r1_src_test
-}
-
-python_test() {
-       local TEST_DIR
-
-       rm -rf "${TMPDIR}"/test
-       distutils_install_for_testing
-       cd tests || die
-       "${PYTHON}" run-tests.py --verbose \
-               --tmpdir="${TMPDIR}"/test \
-               --with-hg="${TEST_DIR}"/scripts/hg \
-               || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
-       use emacs && elisp-site-regen
-
-       elog "If you want to convert repositories from other tools using convert"
-       elog "extension please install correct tool:"
-       elog "  dev-vcs/cvs"
-       elog "  dev-vcs/darcs"
-       elog "  dev-vcs/git"
-       elog "  dev-vcs/monotone"
-       elog "  dev-vcs/subversion"
-}
-
-pkg_postrm() {
-       use emacs && elisp-site-regen
-}