corrected rev-numbering patch wrt 557990. Thanks Lars Wendler for the patch and Danie...
authorAndreas Schuerch <nativemad@gentoo.org>
Mon, 17 Aug 2015 15:06:47 +0000 (17:06 +0200)
committerAndreas Schuerch <nativemad@gentoo.org>
Mon, 17 Aug 2015 15:06:47 +0000 (17:06 +0200)
Package-Manager: portage-2.2.20.1

media-sound/ardour/ardour-4.1.ebuild
media-sound/ardour/ardour-4.2.ebuild
media-sound/ardour/files/ardour-4.x-revision-naming.patch [new file with mode: 0644]

index 4830a49f33ea2c3d4f8a66e58930bc2b75a1c2cc..29167b33e061e07cf189bbadf9c08aff1a5d2bb3 100644 (file)
@@ -84,7 +84,7 @@ src_unpack() {
 
 src_prepare(){
        if ! [ ${PV} = 9999 ]; then
-               epatch "${FILESDIR}"/${PN}-4.0-revision-naming.patch
+               epatch "${FILESDIR}"/${PN}-4.x-revision-naming.patch
                touch "${S}/libs/ardour/revision.cc"
        fi
        $(use lv2 || epatch "${FILESDIR}"/${PN}-4.0-lv2.patch)
index 4830a49f33ea2c3d4f8a66e58930bc2b75a1c2cc..29167b33e061e07cf189bbadf9c08aff1a5d2bb3 100644 (file)
@@ -84,7 +84,7 @@ src_unpack() {
 
 src_prepare(){
        if ! [ ${PV} = 9999 ]; then
-               epatch "${FILESDIR}"/${PN}-4.0-revision-naming.patch
+               epatch "${FILESDIR}"/${PN}-4.x-revision-naming.patch
                touch "${S}/libs/ardour/revision.cc"
        fi
        $(use lv2 || epatch "${FILESDIR}"/${PN}-4.0-lv2.patch)
diff --git a/media-sound/ardour/files/ardour-4.x-revision-naming.patch b/media-sound/ardour/files/ardour-4.x-revision-naming.patch
new file mode 100644 (file)
index 0000000..d558f47
--- /dev/null
@@ -0,0 +1,38 @@
+--- ardour-4.2/wscript
++++ ardour-4.2/wscript
+@@ -162,7 +162,7 @@
+ if os.path.isdir (os.path.join(os.getcwd(), '.git')):
+     rev = fetch_git_revision ()
+ else:
+-    rev = fetch_tarball_revision ()
++    rev = os.environ['PV']
+ #
+ # rev is now of the form MAJOR.MINOR[-rcX]-rev-commit
+@@ -238,16 +238,16 @@
+     return version
+ def create_stored_revision():
+-    rev = ""
+-    if os.path.exists('.git'):
+-        rev = fetch_git_revision();
+-        print("Git version: " + rev + "\n")
+-    elif os.path.exists('libs/ardour/revision.cc'):
+-        print("Using packaged revision")
+-        return
+-    else:
+-        print("Missing libs/ardour/revision.cc.  Blame the packager.")
+-        sys.exit(-1)
++    rev = os.environ['PV'] + "-gentoo"
++#    if os.path.exists('.git'):
++#        rev = fetch_git_revision();
++#        print("Git version: " + rev + "\n")
++#    elif os.path.exists('libs/ardour/revision.cc'):
++#        print("Using packaged revision")
++#        return
++#    else:
++#        print("Missing libs/ardour/revision.cc.  Blame the packager.")
++#        sys.exit(-1)
+     try:
+         #