dev-python/mimerender: Fix tests, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 17:40:02 +0000 (19:40 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 17:50:37 +0000 (19:50 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/mimerender/Manifest
dev-python/mimerender/mimerender-0.6.0.ebuild

index d9b29135cc01f2d7462624198160c7002b7374e8..4e152e230d828e721e59f722b5ba519e996eff1a 100644 (file)
@@ -1 +1 @@
-DIST mimerender-0.6.0.tar.gz 5310 BLAKE2B 92ff2e9dd8544ce64eb00fea230eb5d827cdd76856eb4ec7962ab706081e4e96b97e4bbb1a9131a37d643205e92ec9afb6b2b6b462fddc025a07d201b946eef9 SHA512 0b0f452404d09860cf42b8afef96ac87d4e5b222834b2309a9aa8d4855822b988cc8daaa2a0553332786755a26ff8e65c8cd6fbd4ff390f8534f925524b4222f
+DIST mimerender-0.6.0.gh.tar.gz 16677 BLAKE2B 55db5bf97cd65de89271af8713d9dbdebab6254fa2dc62cfcd78394f4333093fdc508ad6e93f104eee2f3d8a1ceb9197353b4ca085e3b4887b4560c2c65c45f6 SHA512 68c584ba8ae608097b739078dd729bd8b5493087901ba281959abdb81d4e6052ff045c487fde4f67744b413bab36d7f938c68b162049ebe33bff642571b8fd98
index 05935778d43aeb148ffd9a82463cc38af8c685f6..9c2a32f940a650aa1eda3be2561dcdb0db552091 100644 (file)
@@ -1,19 +1,27 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
 DESCRIPTION="RESTful HTTP Content Negotiation for Flask, Bottle, web.py and webapp2"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="https://pypi.org/project/mimerender/"
+HOMEPAGE="
+       https://pypi.org/project/mimerender/
+       https://github.com/martinblech/mimerender/"
+SRC_URI="
+       https://github.com/martinblech/mimerender/archive/v${PV}.tar.gz
+               -> ${P}.gh.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
 
 RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+       "${EPYTHON}" src/test.py -v || die "Tests fail with ${EPYTHON}"
+}