dev-python/transitions: drop old version
authorConrad Kostecki <conrad@kostecki.com>
Mon, 23 Sep 2019 20:52:35 +0000 (22:52 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 24 Sep 2019 05:00:38 +0000 (08:00 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Closes: https://github.com/gentoo/gentoo/pull/12998
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/transitions/Manifest
dev-python/transitions/transitions-0.6.9.ebuild [deleted file]

index 0a84b5eebbfd8602002566d60205d5338fbcf500..1e38264ce1b20f2efd85ca79cc50808e60cd86ec 100644 (file)
@@ -1,2 +1 @@
-DIST transitions-0.6.9.tar.gz 1354465 BLAKE2B bb536c1209c08717b29d5d60e4b31253b1f5bc759b7693a3ef82d4894cd55bc8a2dd3417e03ba5232d35de060c73cef664994c44c8f14be9ed0743170e7c1c09 SHA512 8104d98795c4212e40ba8274332e2e87336421e61a4398c58907a675708cddc7d3b77bbcada1e2cc16fd9dd518c94f07c2079cf0507b8647a435435151f5eb51
 DIST transitions-0.7.1.tar.gz 1283833 BLAKE2B 5f2f2813ba158cf5ccac4e2d55700149b986bdd24f9e864cec8d03390724cf79d9d379afa06b1a7b56c6a91376410252fdda169024f6ebbba2ed976fe7a18e7b SHA512 3fe5989faf9dbfdc15d50beaf2656240317f00278727271e5bd64ad465be1640b67e760fb73f4b06a61920343215815a8be03d41dc4d32086222446463ef71d7
diff --git a/dev-python/transitions/transitions-0.6.9.ebuild b/dev-python/transitions/transitions-0.6.9.ebuild
deleted file mode 100644 (file)
index 65a89da..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
-HOMEPAGE="https://github.com/pytransitions/transitions"
-SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pygraphviz[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-
-DEPEND="
-       ${RDEPEND}
-       test? (
-               dev-python/pycodestyle[${PYTHON_USEDEP}]
-               dev-python/dill[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )
-"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
-       esetup.py test
-}
-
-src_install() {
-       distutils-r1_src_install
-
-       use examples && dodoc examples/*.ipynb
-}